The International Simutrans Forum

Community => Community Discussion => Web & Wiki => Topic started by: Frank on October 31, 2008, 10:20:03 PM

Title: Wrong links in English Wiki
Post by: Frank on October 31, 2008, 10:20:03 PM
the last link on this site http://en.wiki.simutrans.com/index.php/Simutrans_Maps (http://en.wiki.simutrans.com/index.php/Simutrans_Maps) is wrong

http://http//forum.simutrans.com/index.php?board=39.0
Title: Re: Wrong links in English Wiki
Post by: IgorEliezer on November 01, 2008, 12:54:05 AM
The main problem is not only the "http://http//"; the problem may be bigger. This link and others still point to a board that doesn't exist in this forum. That means many other links that pointed to old forum are broken now.

Then, I ask for everyone to post here all links that are broken, so that we can find and fix such links.

Obviously, if a forum member is registered in Wiki, such member is able to fix them too. Even so, if having any doubt how to edit the Wiki, please post here too.

Thanks

Title: Re: Wrong links in English Wiki
Post by: LondonBVE on November 01, 2008, 03:03:27 PM
Looks like I overlook it, thanks for correcting it. It must be pasting the url after typing http://.
Title: Re: Wrong links in English Wiki
Post by: Frank on November 03, 2008, 11:26:58 PM
...
Then, I ask for everyone to post here all links that are broken, so that we can find and fix such links.
...

old forum links on www.simutrans.com
Title: Re: Wrong links in English Wiki
Post by: IgorEliezer on November 04, 2008, 12:29:40 AM
old forum links on www.simutrans.com

Fixed!  :)
Title: Re: Wrong links in English Wiki
Post by: Dwachs on March 04, 2009, 07:45:31 AM
There are more broken links:
  • On http://wiki.simutrans.com/ the link to the japanese wiki is broken
  • On http://de.wiki.simutrans.com/ the link to the german wiki is broken, it should be http://simutrans-germany.com/wiki/wiki/tiki-index.php
  • The English Wiki points to the German wiki with the address http://de.wiki.simutrans-forum.de/index.php/Hauptseite, where some redirection fails.

I suggest to add a link to the dat-reference on the German wiki http://simutrans-germany.com/wiki/wiki/tiki-index.php?page=en_dat_Files
to this page on the English wiki:

http://en.wiki.simutrans.com/index.php/Creating_addons

The pages on the 'German wiki' are partly translated to English (and other languages). Pages in German are usually up-to-date. Any help with translation is appreciated. This wiki allows anonymous edits. But you can ask Frank for accounts, too.

Other wikis (it, fr, sp, ..) can point to the related sites at the German wiki, too.
Title: wiki.simutrans.com
Post by: Frank on October 18, 2009, 11:14:38 AM
wrong links to german and japanese wiki

german - http://simutrans-germany.com/wiki/wiki/tiki-index.php?page_ref_id=1 (http://simutrans-germany.com/wiki/wiki/tiki-index.php?page_ref_id=1)

japanese - http://japanese.simutrans.com/ (http://japanese.simutrans.com/)

Title: Re: wiki.simutrans.com
Post by: Dirk Burkholz on October 18, 2009, 12:43:25 PM
Thanks for the info!

German link is fixed, Japanese one will take a while (DNS update pending).
Title: Re: wiki.simutrans.com
Post by: z9999+ on October 18, 2009, 01:06:44 PM
Sorry, what do you mean DNS thing.
Must we migrate to somewhere else ?

We have been using "japanese.simutrans.com" as permanent url for long time, we don't want to use different url.

Sorry if I misunderstanging you.
Title: Re: wiki.simutrans.com
Post by: Dirk Burkholz on October 18, 2009, 01:08:55 PM
The wiki uses urls like [language code].wiki.simutrans.com. I've created jp.wiki.simutrans.com redirecting to japanese.simutrans.com.
Title: Re: Wrong links in English Wiki (merged: wiki.simutrans.com)
Post by: IgorEliezer on October 18, 2009, 06:27:27 PM
Topic merged.
Title: Re: Wrong links in English Wiki
Post by: z9999+ on October 18, 2009, 08:24:37 PM
Thank you for explaint it. I'm relieved to hear that.

BTW, your redirect has a problem.
It works with Fx but doesn't work with IE8, http://jp.wiki.simutrans.com/ go into an infinite loop.
http://de.wiki.simutrans.com/ is the same.
Title: Re: Wrong links in English Wiki
Post by: VS on October 18, 2009, 08:33:42 PM
Better than creating an empty domain, ask Timothy to create a CNAME DNS pointer instead...

Or make the page (script?) return header "Location: http://japanese.simutrans.com"
Title: Re: Wrong links in English Wiki
Post by: Frank on October 18, 2009, 08:43:19 PM
...
BTW, your redirect has a problem.
It works with Fx but doesn't work with IE8, http://jp.wiki.simutrans.com/ go into an infinite loop.
http://de.wiki.simutrans.com/ is the same.


this is a html error ( by german link since 2 years )

missing URL= in the meta tag
Quote
<meta http-equiv="refresh" content="0;URL=http://japanese.simutrans.com/" />

Title: Re: Wrong links in English Wiki
Post by: z9999+ on October 19, 2009, 12:23:55 AM
this is a html error ( by german link since 2 years )

Thank you but I don't know what you mean. Nobody couldn't repair it for 2 years ?

BTW, why jp.wiki.simutrans.com is needed ?
Changing the link on wiki.simutrans.com from jp.wiki.simutrans.com to japanese.simutrans.com is enough isn't it ?
That is the reason what I asked DNS thing.
Title: Re: Wrong links in English Wiki
Post by: Dirk Burkholz on October 19, 2009, 02:39:02 PM
missing URL= in the meta tag
Shame on me, I didn't see it! Fixed by now.

I strongly encourage to publish the urls wiki.simutrans.com and [language code].wiki.simutrans.com. This way people aren't confused by thousand different wiki urls and the redirect can happen easily if a wiki server/url changes.