The International Simutrans Forum

Development => Patches & Projects => Incorporated Patches and Solved Bug Reports => Topic started by: tfosorcim on November 09, 2008, 01:07:48 PM

Title: Landscape problems - r2101
Post by: tfosorcim on November 09, 2008, 01:07:48 PM
Using Pak128-r229 + 100.1 r2101 Windows SDL
Title: Re: Landscape problems
Post by: VS on November 09, 2008, 01:10:50 PM
This is probably bug of the program and not pak128.

What exactly did you do? Just start Simutrans and the intro map looked like this?
Title: Re: Landscape problems
Post by: tfosorcim on November 09, 2008, 01:12:06 PM
This is probably bug of the program and not pak128.

What exactly did you do? Just start Simutrans and the intro map looked like this?

Yes
Title: Re: Landscape problems
Post by: VS on November 09, 2008, 02:12:42 PM
I reproduced it. It really is an engine bug - Simutrans assumes that the last line before map edge ends at water level. Together with the fact that outside map is shown as water it is a clever way to make maps look a small bit nicer. Thus there isn't anything done with tiles that have "walls" on the edge of map. And the pixels of screen that are in their place just keep colors of what was painted there before. Try moving the view left and right with the end of map visible and you'll see.

It doesn't do anything dangerous as far as I could see - building roads on the tiles caused no problems. Lowering the land at map edge is impossible, but doing this to the last row before it lowered this, too. I am somewhat inclined to believe these are in fact just some erroneous slopes that raise the last tile to be flat instead of proper shape.
Title: Re: Landscape problems - r2101
Post by: prissi on November 09, 2008, 06:44:08 PM
Check next nightly.
Title: Re: Landscape problems - r2101
Post by: Frank on November 09, 2008, 06:54:18 PM
fixed in r2102

Thank you