The International Simutrans Forum

Development => Bug Reports => Topic started by: Lmallet on March 22, 2009, 09:19:01 PM

Title: Crash when building stop
Post by: Lmallet on March 22, 2009, 09:19:01 PM
Simutrans 102.1-2391 on Linux (SDL Opensuse 11.1)
Pak128 v535 with my private road sign and Timothy's fences as add-ons.

I get a segfault every time I try to build a bus stop on a game I've been playing for a while.  I can reproduce it every time with the savegame, but the problem does not seem to exist on a fresh game.

You can find my savegame, log, and add-ons here:  http://drop.io/l3fiqe4

EDIT:  played a bit more.  looks like rotation related.
Title: Re: Crash when building stop
Post by: z9999 on March 23, 2009, 10:42:28 AM
I tried your savegame with Windows GDI/SDL versions, but I couldn't reproduce your problem.

looks like rotation related.

Did the problem happen without building a stop ?
Title: Re: Crash when building stop
Post by: Lmallet on March 23, 2009, 02:08:46 PM
I don't know how to explain it now  ;D

In the savegame above, would crash when I build a stop, but I tried the game later, and if I rotate back to the "default" rotation (ie. the one Simutrans starts in), then the crashes stop.  I crashed it a few more times building roads and rails, but again that was rotated (in my case, click rotate twice from the original view).

I managed to play for 30 simuyears using rotations without a crash.  Maybe it is a pak128 object not liking rotations.



Title: Re: Crash when building stop
Post by: VS on March 23, 2009, 03:10:40 PM
If you find which one it is, please report! But stations, ways and bridges must have all rotations, so I don't see what could be wrong about object :(