Author Topic: [120.0.1 Mac]Crashing on installation  (Read 1266 times)

0 Members and 1 Guest are viewing this topic.

Offline THLeaderH

[120.0.1 Mac]Crashing on installation
« on: March 06, 2015, 11:46:15 AM »
Hello everyone.
I've tried searching this in the forum and the post I found did not resolve this issue.

I've played simutrans in old version, 112.3. I tried to upgrade simutrans to 120.0.1. However, the new simutrans crashed when I opened the simutrans binary. Simutrans 120.0.1 also contains "". So I also tried this, but it also crashed.

Here is the data of my machine
OS version:10.7.5
CPU:Core 2 Duo

When I opened the simutrans binary, I got the following message in Terminal.
Code: [Select]
Illegal instruction: 4Only this was what I got :-X

When I opened the "", I got the following message in a crash reporting window.
Code: [Select]
Process:         launchd [2561]
Path:            /Users/USER/Desktop/*/
Identifier:      org.simutrans.simutrans
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [293]

Date/Time:       2015-03-06 20:43:05.793 +0900
OS Version:      Mac OS X 10.7.5 (11G63)
Report Version:  9

Interval Since Last Report:          158694 sec
Crashes Since Last Report:           43
Per-App Crashes Since Last Report:   24
Anonymous UUID:                      FF14403B-F151-490B-ADCE-14B36ACED4ED

Crashed Thread:  Unknown

Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000055  rbx: 0x0000000000000000  rcx: 0x0000000000000000  rdx: 0x0000000000000000
  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x0000000000000000  rsp: 0x0000000000000000
   r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000000
  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000
  rip: 0x00007fff5fc01028  rfl: 0x0000000000010203  cr2: 0x00007fff5fc01028
Logical CPU: 1

Binary images description not available

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 5168
    thread_create: 1
    thread_set_state: 0

I also installed SDL2. What should I do?

Offline TurfIt

Re: [120.0.1 Mac]Crashing on installation
« Reply #1 on: March 06, 2015, 07:05:15 PM »
Assuming you downloaded given your reference to SDL2, then try instead. It was compiled on a much older cross compiler, and requires SDL1. I suspect the SDL2 compile is targeting a too new CPU for your system. It was made on 10.9.x, with a IvyBridge CPU, and I cannot find any way to tell clang what CPU to target... (surely they wouldn't omit such a vital feature??)

Note the SDL2 version was created due to many reports of extremely poor performance with SDL1. If SDL1 does run for you, but slowly, at this point you'd have to self compile to get a runnable SDL2 I think.

Offline THLeaderH

Re: [120.0.1 Mac]Crashing on installation
« Reply #2 on: March 08, 2015, 12:10:51 AM »
I tried the SDL1 version of simutrans. It contains only So, I opened this but it crushed with no message. I used Terminal to find some error log. Then I got the following message.
Code: [Select]
LSOpenURLsWithRole() failed with error -10810 for the file /Users/USER/Downloads/simutrans/
I complied simutrans from the source code. I selected the SDL2 version in config.default. Then, I succeeded. It works :) . Thank you for your help!