The International Simutrans Forum

 

Author Topic: Trams not filtered  (Read 1674 times)

0 Members and 1 Guest are viewing this topic.

Offline Václav

  • Devotee
  • *
  • Posts: 3325
  • formerly VaclavMacurek
  • Languages: CZ, EN
Trams not filtered
« on: November 17, 2012, 12:07:20 PM »
In vehicle list, vehicle type trams is not allowed to be filtered.

I have some trams in game. I sent some ones into depot - but I did not know to which depot they went.
I wanted to see (in vehicle list) only trams - but no one was showed.
I used some other (special) filters - but they run only alone or with else vehicle types. In all cases no tram is showed.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10829
  • Languages: De,EN,JP
Re: Trams not filtered
« Reply #1 on: November 17, 2012, 03:32:31 PM »
Trams are inteally trains for most purposes. This is rather an extension request (and a quite reasonable one).

Offline Václav

  • Devotee
  • *
  • Posts: 3325
  • formerly VaclavMacurek
  • Languages: CZ, EN
Re: Trams not filtered
« Reply #2 on: November 17, 2012, 05:51:56 PM »
But they are not showed also in group of trains, too.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4899
  • Languages: EN, DE, AT
Re: Trams not filtered
« Reply #3 on: November 17, 2012, 06:04:02 PM »
This is a bug. The filtering is still broken.

Edit: It seems that the enum flags in convoi_filter_frame_t are limited to 16 bits, and thus break some filter buttons.

Edit2: Fixed with r6066.
« Last Edit: November 17, 2012, 07:57:17 PM by Dwachs »