The International Simutrans Forum

 

Author Topic: Alignment/clipping sprite problem r6298  (Read 3646 times)

0 Members and 1 Guest are viewing this topic.

Offline Spacethingy

  • *
  • Posts: 177
Alignment/clipping sprite problem r6298
« on: January 25, 2013, 02:58:03 PM »
Hi guys...  ;D


Some nasty sprite alignment problems seemed to have slipped in:





  • Windows SDL and GDI.
  • Only seems to effect pak64, although I haven't looked at any busy maps in other paks.
  • Found and examined in r6212, checked same in r6298+ pak64-1143
  • I don't know if it's just the shown vehicles this applies to, they seemed the most common though.
  • Found when convoys are created normally in single player, also found when logging onto multiplayer servers (a lot of above pictures found on entropy C server).
Hope this helps, thanks.

(BTW, I posted this here as I'm not 100% sure it's a just pak64 thing - sorry...)

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5531
  • Languages: EN, NO
Re: Alignment/clipping sprite problem r6298
« Reply #1 on: January 25, 2013, 04:26:15 PM »
The telescoping "bugs" have been in pak64 a long time (years). There used to be more of them. I'm not 100% sure about the gap bugs. (I also seen a bug where the last two wagons occupied the same space, but only as a one-off occurence so far.)

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9518
  • Languages: De,EN,JP
Re: Alignment/clipping sprite problem r6298
« Reply #2 on: January 25, 2013, 04:59:56 PM »
Those are usually engines aligned worngly and thus should be pak specific. I will check it.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5531
  • Languages: EN, NO
Re: Alignment/clipping sprite problem r6298
« Reply #3 on: January 25, 2013, 06:46:23 PM »
I have seen gaps suddenly appearing in some cases, but they disappear the next time the train turns around. The BR234 is a chronic misalignment I've mentioned earlier.

My suggestion to allow multiple X2(000) sets has also caused an overlap bug when moving horizontally relative to the screen (diagonally relative to tiles). As the ends are shorter than the coaches (according to Wikipedia), compressing their graphics might be the right thing.

Offline Václav

  • Devotee
  • *
  • Posts: 3267
  • formerly VaclavMacurek
  • Languages: CZ, EN
Re: Alignment/clipping sprite problem r6298
« Reply #4 on: January 25, 2013, 08:41:49 PM »
As I looked at those images, it is similar to matter of wrong alignment of my tram(s) for pak96.comic. When two vehicles of different length are together, one is aligned wrong - but following ones of the same length are aligned right - related to previous one. It is well visible in line 1 and 3 of image
.

I partly corrected this wrong alignment with using of additional alignment coded in dat file (offsets) - but it is not perfect.

Offline greenling

  • Lounger
  • *
  • Posts: 1728
  • Simutransarchology it my hobby!
  • Languages: DE,EN
Re: Alignment/clipping sprite problem r6298
« Reply #5 on: January 25, 2013, 09:55:03 PM »
Yes those problems must we go!

Offline paco_m

  • *
  • Posts: 170
Re: Alignment/clipping sprite problem r6298
« Reply #6 on: February 01, 2013, 08:29:01 AM »
These problems normally are caused by one of the following issues
 
1) you draw views of the vehicle that
doesn't match exactly with the defined length, e.g. you draw actually
a length=7,5 vehicle and assign it as length=8 in the dat file = gap.
 
2) Another possibility is that the vehicle is just aligned in a wrong way,
in this case you can combine it correctly with other vehicles of same
length and alignment but not with vehicle that have other length definitions.
 
3) finally the "telescoped" engines:
pak64 uses a more realistic length for diagonal views (factor 1,4 = shorter) that was not
available in earlier Simutrans version. Some paksets like pak64.german and a lot
of addons still use the old factor=2 and appear much longer in diagonal views
Using this models in pak64 always produces overlaps

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9518
  • Languages: De,EN,JP
Re: Alignment/clipping sprite problem r6298
« Reply #7 on: February 01, 2013, 09:15:38 AM »
Most difficult is the alignment with four views (which also only works with lenght=8) maybe I did a mistake, since Ludmilla is lenght 9 I think.