Simutrans Forum Archive
A complete record of the old Simutrans Forum.

User privilegies in last Pak64 distribution wrong

Started by paco_m, January 13, 2013, 03:01:32 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


If you download and extract the Pak64 112.1 from
all user privilegies (owner, group, others) are set to "no access".

This causes a lot of problems:
1) you can not extract the Zip archive using the directory/folder structure it contains because after creating the directory "pak" it fails to write any file inside this directory because the directory doesn't ahve write permission
2) after fixing this Simutrans won't recognize the installed pak because all the files are unaccesable
The result is that unless you change the permission of every file and directory of Pak64 Simutrans won't load the pak.


Please speak those Problem in the German forum on.
Opening hours 20:00 - 23:00
(In Night from friday on saturday and saturday on sunday it possibly that i be keep longer in Forum.)
I am The Assistant from Pakfilearcheologist!
Working on a big Problem!


I used zip on windows. I doubt that it contians a valid unix ID block, and thus has access rights at all. I could unpack it (on the command line) quite well one unbuntu, this I rather suspect you zip program to wrongly interpret the data.


Tested in my Linux box and unzipping went fine, but files and directories lack permissions so I can't access them afterwards. I tried to create another zip file on my Windows computer, and it's files got normal (default) persmissions when extracted on my Linux box.

So either (or possibly both) prissi's zip program puts bogus Linux permission information into the zip file, or my program generates fake but reasonable Linux permissions information. If (just) the latter, then at least two Linux zip programs have big issues dealing with non-Linux zip files, which seems a bit odd.



The pak128 and pak64.german packages are working without any issues (I only tried this two), so packing the pak64 the same way should solve it.


I paked it already again, this time using 7zip. Does the error still persist?

pak128 is anyway built on linux. Pak64.german was actually paked by exactly the same program as pak64, since I did both.


captain crunch

The permissions are again unset in (excerpt):

$ ls -nl simutrans/pak | head
total 10868
---------- 1 1000 1000  48169 May 17 20:43 bridge.ClassicRail.pak
---------- 1 1000 1000  52879 May 17 20:43 bridge.ClassicRoad.pak
---------- 1 1000 1000  18705 May 17 20:43 bridge.MaglevBridge.pak
---------- 1 1000 1000  26645 May 17 20:43 bridge.ModernRoad.pak
---------- 1 1000 1000  18675 May 17 20:43 bridge.MonorailRamp.pak
---------- 1 1000 1000  18239 May 17 20:43 bridge.PowerBridge.pak
---------- 1 1000 1000  57455 May 17 20:43 bridge.Schiffhebewerk.pak
---------- 1 1000 1000  40279 May 17 20:43 bridge.SteelRail.pak
---------- 1 1000 1000  28545 May 17 20:43 bridge.ViaductRail.pak


Since file permissions is not part of the zip standard (as far as I can see), one should think unzip programs would handle missing permissions better. I guess the zip file says it does actually have UNIX file permissions, but still. It might be that the zipper tries to do a clever mapping from Windows to UNIX file permissions, but screws up over the fact that files on Windows can be set to inherit permissions, which means they usually have no permissions of their own.