Author Topic: Horse-drawn tram with two cars does not leave depot  (Read 8797 times)

0 Members and 1 Guest are viewing this topic.

Offline jeffatsqi

Horse-drawn tram with two cars does not leave depot
« on: January 03, 2009, 04:06:06 AM »
Using pak64v123 with 100.1. The new vehicle interface lets a horse-drawn tram have a second car added. It shows the speed still at 40km/h and the Start options works. However, it never leaves the depot.

If you go to the Line Management, select the new convoy, send it back to depot, remove 2nd car, and ckick start it works.
Simutrans economics labs at www.osnv.org

Offline z9999

Re: Horse-drawn tram with two cars does not leave depot
« Reply #1 on: January 03, 2009, 08:40:32 AM »
40km/h ?



[attachment deleted by admin]

Offline jeffatsqi

Re: Horse-drawn tram with two cars does not leave depot
« Reply #2 on: January 03, 2009, 05:42:34 PM »
Your right. It was 25 km/h. However, the tram did not leave the depot. Let me try again and see if I had some other issue blocking exit.

Thanks

Simutrans economics labs at www.osnv.org

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8830
  • Total likes: 324
  • Helpful: 229
  • Languages: De,EN,JP
Re: Horse-drawn tram with two cars does not leave depot
« Reply #3 on: January 03, 2009, 09:49:51 PM »
No, with three cars, maximum reachable speed is 0km, i.e. you tram will go with 25/16 about 1km/h. Use only two cars.

Offline z9999

Re: Horse-drawn tram with two cars does not leave depot
« Reply #4 on: January 03, 2009, 10:20:54 PM »
Using pak64v123 with 100.1.

100.1 is a little old, I think.
I don't remember too much, but I have had a similar problem once one or two months ago.
So, try latest version first, and if you had the same problem, it might be a problem of program. Please report again with the way to reproduce the problem.

Offline DirrrtyDirk

  • Devotee
  • *
  • Posts: 1253
  • Total likes: 1
  • Helpful: 11
  • JR 700 Series Shinkansen
  • Languages: EN,DE
Re: Horse-drawn tram with two cars does not leave depot
« Reply #5 on: January 03, 2009, 11:20:42 PM »
100.1 is a little old, I think.

Errr... actually 100.0 is old. 100.1 were all the 300+ nightlies until r2197 of 3 or 4 days ago. So "100.1" (without the exact rxxxx number) is not necessarily old - but extremely un-precise.
  
***** PAK128 Dev Team - semi-retired*****

Offline jeffatsqi

Re: Horse-drawn tram with two cars does not leave depot
« Reply #6 on: January 04, 2009, 02:57:51 AM »
Tried again on a different line and it worked. Must have been my error.

btw. the exect version I am using is 100.1-2184
Simutrans economics labs at www.osnv.org

Offline emaxectranspoorte

Re: Horse-drawn tram with two cars does not leave depot
« Reply #7 on: January 04, 2009, 03:22:43 AM »
I had a similar error with this version, as well ... But, that time, it was a simple Bennhardt coal train not coming out of the train depot... 

Simply, save your current map/game ... and restart your version of Simutrans. And reload that same map/game, again...

EDIT: I have the same version, but with pak128.
« Last Edit: January 04, 2009, 03:34:54 AM by emaxectranspoorte »

Offline jeffatsqi

Re: Horse-drawn tram with two cars does not leave depot
« Reply #8 on: January 04, 2009, 04:02:34 AM »
Thanks emaxectranspc,

What you suggested is exactly what I had done between the first time when the tram did not leave the depot and the second test when it did.

Here is an interesting side point. The two car that did not leave the depot however did respond to the return to depot command. So it was active but stuck.
Simutrans economics labs at www.osnv.org

Offline emaxectranspoorte

Re: Horse-drawn tram with two cars does not leave depot
« Reply #9 on: January 04, 2009, 04:05:57 AM »
Here is an interesting side point. The two car that did not leave the depot however did respond to the return to depot command. So it was active but stuck.

I had the same interesting side point with my Bennhardt...
« Last Edit: January 04, 2009, 04:08:46 AM by emaxectranspoorte »

Offline VS

  • Senior Plumber (Devotee)
  • Devotee
  • *
  • Posts: 4849
  • Total likes: 25
  • Helpful: 63
  • Vladimír Slávik
    • VS's Simutrans site
  • Languages: CS,EN
Re: Horse-drawn tram with two cars does not leave depot
« Reply #10 on: January 04, 2009, 10:46:51 AM »
Yes, sometimes vehicles leave depot but stay stuck on the tile with depot. It happened to me several times, too. Usually it happens when the block in front of depot is to be reserved by another train. Only solution is to release convoys from depot carefully, when nothing approaches, and if something is stuck anyway, just remove it (details->sell now).

My projects... Tools for messing with Simutrans graphics. Graphic archive - templates and some other stuff for painters. Development logs for most recent information on what is going on. And of course pak128!

Offline z9999

Re: Horse-drawn tram with two cars does not leave depot
« Reply #11 on: January 04, 2009, 10:47:21 AM »
Tried again on a different line and it worked. Must have been my error.

That's good to hear.

I don't remember too much, but I have had a similar problem once one or two months ago.

I remember, it was on pause mode, not a problem.  ;D

Offline emaxectranspoorte

Re: Horse-drawn tram with two cars does not leave depot
« Reply #12 on: January 05, 2009, 09:23:46 AM »
Usually it happens when the block in front of depot is to be reserved by another train.

 ???

This wasn't the case for me, sorry VS... :o :-\ The block before was completely first time unused. ;) 8)

EDIT: I couldn't sell it before having to return it to the depot. But instead of selling it I did like any person who knows computers and documentation would do, and I restarted Simutrans. Then everything worked fine. :) 8)

EDIT2: This wasn't without a pause mode on... :)
« Last Edit: January 05, 2009, 09:30:10 AM by emaxectranspoorte »

Offline Lodovico

Re: Horse-drawn tram with two cars does not leave depot
« Reply #13 on: January 05, 2009, 11:41:42 AM »
I have to confirm this.
I can compose a horse tram with ANY number of passenger cars, but such a tram never leaves the depot:


[attachment deleted by admin]

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8830
  • Total likes: 324
  • Helpful: 229
  • Languages: De,EN,JP
Re: Horse-drawn tram with two cars does not leave depot
« Reply #14 on: January 05, 2009, 02:45:37 PM »
Works fine for me. Tested on two different computers.

Offline Lodovico

Re: Horse-drawn tram with two cars does not leave depot
« Reply #15 on: January 06, 2009, 08:39:28 AM »
I was somehow hotheaded yesterday.
It works. Sorry.

[attachment deleted by admin]