The International Simutrans Forum

 

Author Topic: Underground station labels placed wrong  (Read 2593 times)

0 Members and 1 Guest are viewing this topic.

Offline HDomos

  • *
  • Posts: 153
  • Languages: EN, DE, FR, HU
Underground station labels placed wrong
« on: January 15, 2013, 01:07:07 AM »
If i build a station underground, the label of it is placed wrong (the deeper it is the worse the placement will be). I made a few screenshots to demostrate it. The strange is, that if i'm in sliced mode on the level of the station, the label is OK, and when i use the "go up one level" button it moves in the opposite direction as it should. The pictures are from the same position, and on the ground level, the label is sompletely out of place... The station begins one tile west from the parking place(stop), and thats where the label should be.





Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4601
  • Languages: EN, DE, AT
Re: Underground station labels placed wrong
« Reply #1 on: January 15, 2013, 06:40:33 AM »
where are the pictures ?

Offline HDomos

  • *
  • Posts: 153
  • Languages: EN, DE, FR, HU
Re: Underground station labels placed wrong
« Reply #2 on: January 15, 2013, 11:59:40 AM »
where are the pictures ?
You can't see them? They are here for me... The label of "Örkény Blaha Luiza tér p.u." is the wrong one
« Last Edit: January 15, 2013, 12:05:24 PM by HDomos »

Offline mEGa

  • 2D painter
  • Devotees (Inactive)
  • *
  • Posts: 1041
  • Pak128 graphics
    • mEGa_Simutrans
  • Languages: FR, EN, ru
Re: Underground station labels placed wrong
« Reply #3 on: January 15, 2013, 12:02:58 PM »
I see them too.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5542
  • Languages: EN, NO
Re: Underground station labels placed wrong
« Reply #4 on: January 15, 2013, 04:08:57 PM »
Looks like labels for underground stops get a double y-offset due to depth. It also affects the old style underground view.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4601
  • Languages: EN, DE, AT
Re: Underground station labels placed wrong
« Reply #5 on: January 15, 2013, 07:11:12 PM »
Hard to fix. Technically these labels sit on the surface, and their offset is adjusted for underground view.

Offline ӔO

  • Devotees (Inactive)
  • *
  • Posts: 2345
  • Hopefully helpful
  • Languages: en, jp
Re: Underground station labels placed wrong
« Reply #6 on: January 15, 2013, 09:02:24 PM »
I think it would be a slight improvement, although not a full fix, if the station label were automatically centred above the most central part of the station instead of the first piece built.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5542
  • Languages: EN, NO
Re: Underground station labels placed wrong
« Reply #7 on: January 16, 2013, 05:26:40 AM »
Having done some work in determining the central point of something, such a seemingly simple thing is unexpectedly complicated to express through logic (you normally don't want the center point inside a hole in the middle). It might or might not be simpler with tiles than with polygons. I think it's a different problem from this, though. The problem here lies along the z-axis, while centering on station would happen on the xy-plane.