The International Simutrans Forum

 

Author Topic: [RC] Braking for Waypoints  (Read 2061 times)

0 Members and 1 Guest are viewing this topic.

Offline Carl

  • Devotee
  • *
  • Posts: 1600
    • Website
  • Languages: EN
[RC] Braking for Waypoints
« on: March 16, 2013, 09:40:53 AM »
In the RC, convoys appear to brake for non-reversing waypoints -- a bug which I believe had been removed from previous 10.x versions.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [RC] Braking for Waypoints
« Reply #1 on: March 17, 2013, 12:18:48 AM »
Thank you for the report - I have been able to reproduce this. Bernd - would you be able to look into this one?

Offline Bernd Gabriel

  • *
  • Posts: 230
  • Addicted to Simutrans: since 2003
    • Fast Function Factory
  • Languages: DE, EN, C++
Re: [RC] Braking for Waypoints
« Reply #2 on: March 23, 2013, 02:53:26 PM »
I fixed this issue in my 112.x-private-cars-merge branch.

@James: I added required parantheses to your addition of revision: 651b5448cbad46fea0fde9f20ee12f0ffec398e5 from 03.11.2012 22:23:57 (Message: FIX: Crash on re-routing in some cases.)
If you remember how to test the addition, you should re-test it.


Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [RC] Braking for Waypoints
« Reply #3 on: March 23, 2013, 05:46:51 PM »
Thank you for that. I can't see where you've added the brackets - are you sure that you committed that one?

Offline Bernd Gabriel

  • *
  • Posts: 230
  • Addicted to Simutrans: since 2003
    • Fast Function Factory
  • Languages: DE, EN, C++

Offline Carl

  • Devotee
  • *
  • Posts: 1600
    • Website
  • Languages: EN
Re: [RC] Braking for Waypoints
« Reply #5 on: March 27, 2013, 05:20:03 PM »
There's something very strange going on in the latest RC. It boils down to "trains going slowly where there's no reason for them to do so", but I haven't been able to pin down anything more detailed than that yet. It's not just braking for waypoints. It could be braking for signals, or misreading speed limits.

The reason it's hard to pin down is that convoys seem to start behaving as they should whenever they are selected. (That sounds ridiculous, I know!)

Has something like this been observed already by others? If not, I'll post a savegame which you can observe in both 10.x and the RC.


Edit: here's one extra detail, at least: the problem manifests itself as convoys travelling at 48kph when there is no reason for them to be going so slow. When selected, they will immediately accelerate.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [RC] Braking for Waypoints
« Reply #6 on: March 28, 2013, 09:56:56 AM »
Hmm - the behaviour of behaving correctly when selected was observed  with an earalier error -  now fixed - when conovyss would be stationary upon loading. I wonder whether the two are related...?

Offline Carl

  • Devotee
  • *
  • Posts: 1600
    • Website
  • Languages: EN
Re: [RC] Braking for Waypoints
« Reply #7 on: March 28, 2013, 10:00:35 AM »
Yes, that occurred to me too. One difference is that the slow-moving state does not seem to appears immediately on loading, unlike the previous stationary error -- that is, convoys may be behaving correctly upon loading of a savegame but then later become slow.

Offline Bernd Gabriel

  • *
  • Posts: 230
  • Addicted to Simutrans: since 2003
    • Fast Function Factory
  • Languages: DE, EN, C++
Re: [RC] Braking for Waypoints
« Reply #8 on: March 28, 2013, 05:30:39 PM »
A savegame and a hint, which convoy when starts loitering would be helpful to see, whether the last fix also fixed this issue.

Offline Carl

  • Devotee
  • *
  • Posts: 1600
    • Website
  • Languages: EN
Re: [RC] Braking for Waypoints
« Reply #9 on: March 28, 2013, 07:10:31 PM »
Here's a savegame (plus pak folder).

https://dl.dropbox.com/u/61716/slow.rar

If you fast forward, the convoys you see moving in the location in the frame on loading can be caught travelling slowly after a while. They seem to be travelling at 64kph on this section of track (not 48 as I previously said). But, as mentioned above, they will switch to behaving normally when you select them.

Since 64 and 48 correspond to track speed limits used on this map, I wonder whether this bug is related to convoys not properly recognising changes in track speed limit.
« Last Edit: March 28, 2013, 07:19:32 PM by Carl »

Offline Bernd Gabriel

  • *
  • Posts: 230
  • Addicted to Simutrans: since 2003
    • Fast Function Factory
  • Languages: DE, EN, C++
Re: [RC] Braking for Waypoints
« Reply #10 on: March 29, 2013, 10:49:42 AM »
Thanks Carl. The last fix fixed this issue as well.

Offline Carl

  • Devotee
  • *
  • Posts: 1600
    • Website
  • Languages: EN
Re: [RC] Braking for Waypoints
« Reply #11 on: March 29, 2013, 10:55:39 AM »
Thanks very much, Bernd!

To clarify - the fix Bernd referred to wasn't part of the latest RC 11.90001 published by James?

Offline Bernd Gabriel

  • *
  • Posts: 230
  • Addicted to Simutrans: since 2003
    • Fast Function Factory
  • Languages: DE, EN, C++
Re: [RC] Braking for Waypoints
« Reply #12 on: March 29, 2013, 11:23:59 AM »
No. The fix I'm talking about is still in my branch only. I think it will be part of 11.9002.

Offline Carl

  • Devotee
  • *
  • Posts: 1600
    • Website
  • Languages: EN
Re: [RC] Braking for Waypoints
« Reply #13 on: March 29, 2013, 02:38:45 PM »
Yes, this is fixed in 11.9002 - many thanks Bernd! :)