The International Simutrans Forum

 

Author Topic: Block Signals Behaviour  (Read 1255 times)

0 Members and 1 Guest are viewing this topic.

Offline Carl

  • Devotee
  • *
  • Posts: 1599
    • Website
  • Languages: EN
Block Signals Behaviour
« on: April 10, 2013, 08:12:10 AM »
I've noticed some odd behaviour with long block signals. Here's a quick video to demonstrate:


http://www.youtube.com/watch?v=rBZFa9LoyzM&feature=youtu.be


The northbound train should be clear to depart as soon as the southbound train enters the platform. But you can see that it makes several failed attempts to route before finally being allowed to leave. (In fact, it seems to be unable to leave until the southbound train has cleared the other block signal - suggesting that this convoy retains its prior reservation even while in the station.) Even when the northbound train departs, its reservation shows up abnormally -- the red line does not cover its complete route.

Offline greenling

  • Lounger
  • *
  • Posts: 1728
  • Simutransarchology it my hobby!
  • Languages: DE,EN
Re: Block Signals Behaviour
« Reply #1 on: April 10, 2013, 03:24:57 PM »
Hello Carl
In Stations gives it unmarked Signals they no be view and that´s make sometimes problems.
Place the Block Signals on the next tile than must it work.

Offline Carl

  • Devotee
  • *
  • Posts: 1599
    • Website
  • Languages: EN
Re: Block Signals Behaviour
« Reply #2 on: April 10, 2013, 07:15:33 PM »
Ah, so if the signals are not on platform tiles, this will not occur? That's helpful, thanks. Nevertheless, this still seems like a bug.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18721
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Block Signals Behaviour
« Reply #3 on: April 10, 2013, 07:34:19 PM »
May I check - did that solve the problem?

Offline Carl

  • Devotee
  • *
  • Posts: 1599
    • Website
  • Languages: EN
Re: Block Signals Behaviour
« Reply #4 on: April 10, 2013, 07:38:12 PM »
I've just checked this, and the answer is no -- even if the block signal is not placed on the station tile, but one tile later, the convoys still exhibit the same behaviour as in the video.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18721
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Block Signals Behaviour
« Reply #5 on: April 10, 2013, 07:43:02 PM »
Can you upload a saved game in which this problem can reliably be reproduced?

Offline Carl

  • Devotee
  • *
  • Posts: 1599
    • Website
  • Languages: EN
Re: Block Signals Behaviour
« Reply #6 on: April 11, 2013, 06:59:46 AM »
While making a toy example of this to upload, I've figured out the cause.

The line north from Merthyr Vale is single track until its end. The block signal invites a convoy to reserve its entire route *until the next signal*. This means that it's attempting to reserve its trip all the way to the end of the line and then back to Merthyr Vale at once -- so it's trying to reserve the spot that the other train is occupying. So, it can't successfully do this until this southbound train has left the station. I can remedy this by putting another signal just after the entrance of the southbound platform.

So this isn't strictly a bug after all, I think.

Offline kierongreen

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 2269
Re: Block Signals Behaviour
« Reply #7 on: April 11, 2013, 11:31:11 AM »
Indeed. This behaviour is intended and necessary :)