The International Simutrans Forum

 

Author Topic: How do I get the correct versions for the online bridgewater-brunel game?  (Read 1243 times)

0 Members and 1 Guest are viewing this topic.

Offline neroden

  • Devotees (Inactive)
  • *
  • Posts: 831
  • Nathanael Nerode
It would be nice if you would make a sticky topic linking to the current, correct versions of the pakset and executable.   I'd be fine with just a git tag name, actually, since I can compile myself.  At the moment I simply can't figure out what version I need to check it out.

Offline ӔO

  • Devotees (Inactive)
  • *
  • Posts: 2345
  • Hopefully helpful
  • Languages: en, jp
you need pakset version 0.8.4 with experimental 10.27

then you need to load the game with "net:bridgewater-brunel.me.uk"

you can't use the networking tool, because of capital/lower case mismatches between linux and windows versions.

Offline neroden

  • Devotees (Inactive)
  • *
  • Posts: 831
  • Nathanael Nerode
Quote
you can't use the networking tool, because of capital/lower case mismatches between linux and windows versions.

Ick.  I should be able to fix THAT.  Where are the mismatches?

Offline neroden

  • Devotees (Inactive)
  • *
  • Posts: 831
  • Nathanael Nerode
you need pakset version 0.8.4 with experimental 10.27

then you need to load the game with "net:bridgewater-brunel.me.uk"
I don't know how to make this work.  I have what appears to be pakset 0.8.4.  I can't make this work.

Offline asaphxiix

  • *
  • Posts: 723
what happens when you try to load the game from the "load game" menu?

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 20274
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
You need to type net:bridgewater-brunel.me.uk in the load game dialogue. This issue should be fixed in the next version: indeed, Vonjo is running a server with the latest RC and Pak128, and this issue is not present there: one can join properly using the dialogue.