The International Simutrans Forum

 

Author Topic: Some 0.9.0 issue  (Read 3280 times)

0 Members and 1 Guest are viewing this topic.

Offline Milko

  • Devotee
  • *
  • Posts: 828
Some 0.9.0 issue
« on: July 11, 2013, 08:15:18 PM »
Hello

I found some issue on the last 0.9.0 version:

1) Airplane ATR 72_500 FarnairEurope, post version has payload not recalculated with new method
2) Airplane 727_Adv (DHL), post version has payload not recalculated with new method
3) bus: yorkshire-steam-tank, use axles_load=9 but I think the correct parameter is axle_load=9
4) bus: mcnamara has parameter LOADING_TIME (is it correct?)
5) bus: carts.dat has a space in EmptyImage[ S]=./images/MailCartNew.0.2
6) bus: parcel-coach has a space EmptyImage[ S]=./images/parcel-coach.0.2

Giuseppe

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18241
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Some 0.9.0 issue
« Reply #1 on: July 11, 2013, 10:22:56 PM »
Thank you very much - all fixed on my Github repository.

Offline Milko

  • Devotee
  • *
  • Posts: 828
Re: Some 0.9.0 issue
« Reply #2 on: July 11, 2013, 10:34:26 PM »
Hello James

I'm working on a excel macro that transform dat files on a excel table (using the macro I found the issue).

Paramters:
available_only_as_upgrade
fixed_maintenance
overcrowded_capacity

are valid?

Giuseppe

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18241
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Some 0.9.0 issue
« Reply #3 on: July 11, 2013, 10:40:05 PM »
"fixed_cost" should be used instead of "fixed_maintenance", as the former, but not the latter, also works in Standard. "available_only_as_upgrade" and "overcrowded_capacity" are indeed valid parameters.

And that is a very interesting idea!

Offline greenling

  • Lounger
  • *
  • Posts: 1728
  • Simutransarchology it my hobby!
  • Languages: DE,EN
Re: Some 0.9.0 issue
« Reply #4 on: July 12, 2013, 01:48:56 PM »
Hello Jamespetts
Gives those Bug in Pak128.britain exp 0.9.0 Too: http://forum.simutrans.com/index.php?topic=12148.0

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18241
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Some 0.9.0 issue
« Reply #5 on: July 12, 2013, 05:24:58 PM »
Greenling - thank you for noticing that the bug is also present in Experimental. I shall incorporate the fix when one is made for Standard.

Offline greenling

  • Lounger
  • *
  • Posts: 1728
  • Simutransarchology it my hobby!
  • Languages: DE,EN
Re: Some 0.9.0 issue
« Reply #6 on: July 12, 2013, 11:09:01 PM »
Hello Jamespetts
I Have fund some possible Bugs more: http://forum.simutrans.com/index.php?topic=12009.0

Offline Milko

  • Devotee
  • *
  • Posts: 828
Re: Some 0.9.0 issue
« Reply #7 on: July 16, 2013, 07:54:54 PM »
Hello

Some other issue

7) train GWR-Autocoach, first line is "GWR aobj=vehicle" (and parameter name is missing)
8 ) boats/holds: scooner-holds, brig-holds, clipper-holds has ",," in all the "east" lines, example: "EmptyImage[E]=../images/holds.0.0,,40,56"
9) (maybe not a  bug but intended) LMS-Mail and LMS-TPO are commented, is intended?

Giuseppe

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18241
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Some 0.9.0 issue
« Reply #8 on: July 16, 2013, 09:37:23 PM »
Thank you very much for those - errors nos. 1 and 2 fixed. No. 3 is intended, as indicated by the "#DEPRECATED" line: these carriages have been replaced with something more specific.

Offline Milko

  • Devotee
  • *
  • Posts: 828
Re: Some 0.9.0 issue
« Reply #9 on: July 16, 2013, 10:22:45 PM »
Hello James

There is a pull request for you, problem 8 ) has other occourencies, I fix them in my payload branch.  :)


Giuseppe

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18241
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Some 0.9.0 issue
« Reply #10 on: July 16, 2013, 10:54:57 PM »
Thank you - pulled.

Offline Milko

  • Devotee
  • *
  • Posts: 828
Re: Some 0.9.0 issue
« Reply #11 on: July 22, 2013, 08:56:00 PM »
Hello James

10) city-building-res-1890.dat, "cluster" -> "clusters"
11) trains: c2c-357.dat, there is a line: 87#?
12) trains: ims-push-pull, mr- push-pull (two occourencies): "uptrade_price"
13) ways: iron-arm-rail, iron-bowstring-girder: "reitre_year
14) ways: tube-tunnel.dat: way=LT_TUNNEL_TRACK (is it correct?)

upgrade_price and upgrade_cost, are both valid parameters?

EDIT:
Some industry has two spaces in the parameters:
passenger_demand = 1
mail_demand = 1
Can I remove the spaces?
passenger_demand=1
mail_demand=1

The removal would give me compatibility with excel macro that I'm making ...

Giuseppe
« Last Edit: July 22, 2013, 09:48:38 PM by Milko »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18241
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Some 0.9.0 issue
« Reply #12 on: July 22, 2013, 11:40:53 PM »
Giuseppe,

thank you for pointing these out: they are now fixed (apart from no. 14, which is not a bug: this is there to produce the tunnel graphics).

As to the spaces in the industry parameters, feel free to remove them.

Offline Milko

  • Devotee
  • *
  • Posts: 828
Re: Some 0.9.0 issue
« Reply #13 on: July 24, 2013, 04:40:27 PM »
Hello

15) trains: gwr-pr-railcar: tracive_effort

Giuseppe

Offline ӔO

  • Devotees (Inactive)
  • *
  • Posts: 2345
  • Hopefully helpful
  • Languages: en, jp
Re: Some 0.9.0 issue
« Reply #14 on: July 24, 2013, 04:54:09 PM »
727 100 foods is mislabelled as 727 200.

Offline Milko

  • Devotee
  • *
  • Posts: 828
Re: Some 0.9.0 issue
« Reply #15 on: July 25, 2013, 02:13:20 PM »
hello

16) industry: grocers: eelectricity_amount=1
17) goods: goods-128: in canned food there is a missing # after class
18) narrowgauge: george-england and hunslet-alice: missing # after http:

Giuseppe

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18241
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Some 0.9.0 issue
« Reply #16 on: July 25, 2013, 08:25:33 PM »
Thank you very much for spotting those - found and fixed.

As to the grocer, it was powered by electric eels.