News:

Simutrans Sites
Know our official sites. Find tools and resources for Simutrans.

Problem on Compilng Simutrans with Eclipse

Started by mrho888, September 22, 2013, 02:07:58 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

mrho888

I am using Eclipse CDT.
What should I do after I import all the files into a new Project?
I have click Run but it said "Binary not found"
Is that I need to build it first ?

Ters

I seriously doubt any existing Simutrans developer uses Eclipse, although I have no clue as to what the Japaneese community are doing. You must of course build Simutrans before you can run it. I would have expected Eclipse to understand that and do it for you. You might have more luck asking this question to the Eclipse community.

mrho888

but I got many error when I tried to build it
for example :
http://forum.simutrans.com/index.php?topic=10794.0
Quote from: Ters on November 08, 2012, 05:44:37 AM
Are you trying to compile it as an independent file? Don't do that. simgraph16.c will include it and feed it what it needs.
How can I build the project "partially" ?
(I am new to simutrans development and I am sorry for my "stupidness" but I really have the passion on simutrans development.)

kierongreen

#3
Look in Makefile for files to create a project from in Eclipse. Note that some files are only required with certain Compile options (depending on whether you are compiling for Windows or Linux, with SDL or GDI backend etc). Also note that there are quite a few libraries that you'll need to link against and/or have header files for. If you aren't used to creating projects in Eclipse I'd suggest using either the Microsoft Compiler or GNU Make which are supported.

VS


My projects... Tools for messing with Simutrans graphics. Graphic archive - templates and some other stuff for painters. Development logs for most recent information on what is going on. And of course pak128!

kierongreen