The International Simutrans Forum

 

Author Topic: [nightly] Clipping error with gui_titlebar_height  (Read 1644 times)

0 Members and 1 Guest are viewing this topic.

Offline z9999+

  • Coder/patcher
  • *
  • Posts: 377
[nightly] Clipping error with gui_titlebar_height
« on: April 23, 2014, 11:59:03 PM »
I'm not sure gui_titlebar_height is a hidden feature or not, because it is not written in themes.tab.
I wrote 'gui_titlebar_height=20' in themes.tab, and found a clipping problem.
When I click and activate a toolbar, titlebar color of deactivated toolbar doesn't change its color correctly. (partially change)

- It happens only with toolbar, and doesn't happen with other window.
- It doesn't happen on water tile. (Because of animation ?)

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1227
    • Simutrans-BLOG
  • Languages: ES
Re: [nightly] Clipping error with gui_titlebar_height
« Reply #1 on: April 24, 2014, 02:01:10 AM »
The size of the bar combines very well with "standard-large"  :thumbsup:



Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5542
  • Languages: EN, NO
Re: [nightly] Clipping error with gui_titlebar_height
« Reply #2 on: April 24, 2014, 04:37:51 AM »
- It happens only with toolbar, and doesn't happen with other window.

I have seen it happen with other windows, but that was long ago.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4601
  • Languages: EN, DE, AT
Re: [nightly] Clipping error with gui_titlebar_height
« Reply #3 on: April 24, 2014, 06:59:45 PM »
fixed with r7167