The International Simutrans Forum

 

Author Topic: Inconsistency in default configuration (meters_per_tile and passenger_factor)  (Read 1775 times)

0 Members and 1 Guest are viewing this topic.

marginoferror

  • Guest
In the default Simutrans Experimental simuconf.tab file, in 11.35, there is an inconsistency: meters_per_tile is set to 250, but passenger_factor is set to 16.  The comments for passenger_factor say: "16 is calibrated to be correct for 125m/tile. This should be doubled for every halving of the meters per tile setting, and halved for every doubling thereof."

Is this discrepancy intentional?  What are some good recommended settings for these values?  My computer is fairly powerful so I'm tempted to try a 125m/tile setup and keep the passenger factor as it is.

Regardless of whether the default is intentional, I have some questions about the passenger_factor comments.  Why would I want to increase the passenger factor if the meters_per_tile is decreased? Shouldn't it be the other way around, where there are more passengers per tile if the tiles are larger?  Also, it seems like area increases by the square of meters_per_tile, so perhaps passenger_factor should increase proportional to area rather than linear length of a side?

Are there other settings that I need to change if I modify meters_per_tile?

Offline Junna

  • Devotee
  • *
  • Posts: 1082
In the default Simutrans Experimental simuconf.tab file, in 11.35, there is an inconsistency: meters_per_tile is set to 250, but passenger_factor is set to 16.

I assume that this is because this setting is always defined by the pak-set's distance per tile setting (pak.britain.ex being 125). Thus the main config' files setting is not very important as generally it is always overruled by the pak-specific setting.