The International Simutrans Forum

 

Author Topic: "string too long" - Can't load savegame anymore  (Read 2475 times)

0 Members and 1 Guest are viewing this topic.

Vindobona

  • Guest
"string too long" - Can't load savegame anymore
« on: November 12, 2014, 04:15:55 AM »
Hy! I have a similar problem as this person here http://forum.simutrans.com/index.php?topic=13084.0

I'm playing a savegame for 2 or 3 years now - and now i have a new PC, using Ubuntu 14.04 LTS (instead of an older version i guess) and on the one hand i cant start the game when installing (unpacking) it on the desktop (as it always worked)

but when i get the game to work, using software center for installation, i cant load my old savegame! It shows this:

FATAL ERROR: loadsave_t::rdwr_str()
string longer (63190) than allowed size (1024)
PRESS ANY KEY
[CRASH]

instead of "63190" there's another number every time i try to load an old savegame file. but its always higher than 1024 ;)

so what does this mean? what can i do?

is the map too large (bigger than 1024x1024?), do I have too much pak files (I added downloaded pak files and files from pak128german to the pak128 folder (which I balanced out so it NEVER crashed until now with the new ubuntu and probably a different simutrans version installed (jsut copying the old files didnt work...))

thx for help!

Vindobona

  • Guest
Re: "string too long" - Can't load savegame anymore
« Reply #1 on: November 12, 2014, 04:24:29 AM »
the savegames are from Simutrans 112.3 r6520 - the current simutrans version is only 111.3.1 - but that's because I cant get simutrans to run when i unpack it manually or i.e. copy all files from my old computer. and when i use software center for installation, i cant choose the versions i want, it just picks the 111.3.1.! when i pick the correct versions by myself and unpack everything, nothing happens when i double click the "simutrans" application start file! how can this be?

Offline kierongreen

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 2346
Re: "string too long" - Can't load savegame anymore
« Reply #2 on: November 12, 2014, 05:41:18 PM »
If nothing happens at all you might need to make sure you've downloaded both the executable and a pakset, and also try setthing executable flags for the simutrans file if they aren't already.

Vindobona

  • Guest
Re: "string too long" - Can't load savegame anymore
« Reply #3 on: November 13, 2014, 11:34:30 PM »
I downloaded and unpacked simutrans 112.3 (executable) from here: (the simulinux version of course) http://sourceforge.net/projects/simutrans/files/simutrans/112-3/

then i downloaded pak128 112.2 (because there is no pak128 112.3), also from sourceforge: http://sourceforge.net/projects/simutrans/files/pak128/pak128%20for%20112-2/ and unpacked the pak files IN the simutrans folder - but the "simutrans" start file doesnt react, even when i click "open as: executable" (or how this is translated - i speak german - "als anwendung öffnen")

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5691
  • Languages: EN, NO
Re: "string too long" - Can't load savegame anymore
« Reply #4 on: November 14, 2014, 06:18:37 AM »
This discussion seems to be in the wrong board. It might get more attention if it isn't filed under already solved problems.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10636
  • Languages: De,EN,JP
Re: "string too long" - Can't load savegame anymore
« Reply #5 on: November 14, 2014, 09:33:37 AM »
It might as well be a wrong library since the exe is a 32bit exe. There is a 64bit nightly. However, for german speakers I recommend the German forum: http://www.simutrans-forum.de/ where you can get also german answers.

Vindobona

  • Guest
Re: "string too long" - Can't load savegame anymore
« Reply #6 on: November 15, 2014, 11:04:15 PM »
Seems that the problem has to do something with the libraries ... after installation of Simutrans 112.3 from here https://launchpad.net/~saiarcot895/+archive/ubuntu/myppa (112.3-0ubuntu1~ppa4~trusty1 ) it worked again!

But now I have another problem: When clicking on a depot, the game just crashes ^^

I posted this new issue here: http://forum.simutrans.com/index.php?topic=14124.0

thx for help anyway ;)
« Last Edit: November 15, 2014, 11:29:20 PM by Vindobona »