Author Topic: Forum issues  (Read 2012 times)

0 Members and 1 Guest are viewing this topic.

Offline Junna

Forum issues
« on: June 02, 2015, 12:57:36 AM »
For about a year now I have an error upon loading the website:

Quote
Connection Problems Sorry, SMF was unable to connect to the database.  This may be caused by the server being busy.  Please try again later.
 Warning:  Cannot modify header information - headers already sent by (output started at /home/sus/_forum/Sources/Errors.php:415) in /home/sus/_forum/Sources/Errors.php on line 346
 
 Warning:  Cannot modify header information - headers already sent by (output started at /home/sus/_forum/Sources/Errors.php:415) in /home/sus/_forum/Sources/Errors.php on line 347
 
 Warning:  Cannot modify header information - headers already sent by (output started at /home/sus/_forum/Sources/Errors.php:415) in /home/sus/_forum/Sources/Errors.php on line 348
 
 Warning:  Cannot modify header information - headers already sent by (output started at /home/sus/_forum/Sources/Errors.php:415) in /home/sus/_forum/Sources/Errors.php on line 351
 
 Warning:  Cannot modify header information - headers already sent by (output started at /home/sus/_forum/Sources/Errors.php:415) in /home/sus/_forum/Sources/Errors.php on line 352
 
 Warning:  Cannot modify header information - headers already sent by (output started at /home/sus/_forum/Sources/Errors.php:415) in /home/sus/_forum/Sources/Errors.php on line 353

One has to reload 2-3 times before the forum actually loads.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4856
  • Total likes: 200
  • Helpful: 108
  • Languages: EN, NO
Re: Forum issues
« Reply #1 on: June 02, 2015, 04:52:46 AM »
I have seen this only occasionally.

One has to reload 2-3 times before the forum actually loads.

Considering the error says that the server might be busy, you hitting reload might actually only make it worse.

Offline Isaac.Eiland-Hall

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3427
  • Total likes: 317
  • Helpful: 91
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: Forum issues
« Reply #2 on: June 02, 2015, 10:07:42 AM »
That's really odd that you would get that. It's the type of message that shouldn't matter where you are in relation to the server, since it's not your browser that connects to the database, but the forum script on the server itself.

I'll see what I can find out, though, of course, since that's my job to do...

I'm very sorry this has been happening to you. :(

edit: I've searched 50 pages of error logs and got nothing. Next time it happens, can you note the time as exactly as you can and reply here? GMT is fine, or your local timezone if you can tell me how far away from GMT you are :)

Offline Junna

Re: Forum issues
« Reply #3 on: June 02, 2015, 04:30:02 PM »
Just did, now. A minute or two ago. 18:28 my time.

Note that this happens only when I'm logged in, and did not happen before a certain browser update (but this was so long ago that I cannot recall, but it happens on Chrome as well as Firefox, so it might just be a temporal accident).

Offline Isaac.Eiland-Hall

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3427
  • Total likes: 317
  • Helpful: 91
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: Forum issues
« Reply #4 on: June 02, 2015, 08:19:39 PM »
..........................so the thought occurs to me that if it can't get to the database, it can't write the error. :|

My next thought is perhaps some sort of user settings that might cause it to time out. I'll experiment when I have time - should be tomorrow. I'll remind myself to come back to this topic.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4856
  • Total likes: 200
  • Helpful: 108
  • Languages: EN, NO
Re: Forum issues
« Reply #5 on: June 03, 2015, 05:25:45 AM »
..........................so the thought occurs to me that if it can't get to the database, it can't write the error. :|

Errors are only written to the database? That sounds fragile, especially since failure to connect to or use the database is the most common reason for system failures (in my experience).

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4856
  • Total likes: 200
  • Helpful: 108
  • Languages: EN, NO
Re: Forum issues
« Reply #6 on: June 07, 2015, 08:17:47 AM »
The forum was a bit slow just five minutes ago, but no error message.

Offline Junna

Re: Forum issues
« Reply #7 on: June 11, 2015, 05:51:30 PM »
Hmm, I don't seem to experience this any more, for now?

Offline Isaac.Eiland-Hall

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3427
  • Total likes: 317
  • Helpful: 91
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: Forum issues
« Reply #8 on: June 11, 2015, 09:02:40 PM »
Haven't made any changes, but who knows. :-S

I mean, uh, I totally fixed it! ;-)