Author Topic: The signal transfer tool doesn't work with colour light signals  (Read 674 times)

0 Members and 1 Guest are viewing this topic.

Offline Rollmaterial

The signal transfer tool doesn't work with colour light signals
« on: December 12, 2016, 08:15:07 PM »
As in title. Additionally, the automatic semaphore combined signals don't auto-upgrade to their colour light counterparts.

Offline jamespetts

  • Simitrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 16075
  • Total likes: 438
  • Helpful: 177
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: The signal transfer tool doesn't work with colour light signals
« Reply #1 on: December 13, 2016, 01:21:25 AM »
Thank you - I think that I have found and fixed both of these. Would you be able to re-test?
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

Offline Rollmaterial

Re: The signal transfer tool doesn't work with colour light signals
« Reply #2 on: December 13, 2016, 04:17:03 PM »
Transferring individual signals now seems to work, but transferring all signals of a signalbox doesn't.

Offline jamespetts

  • Simitrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 16075
  • Total likes: 438
  • Helpful: 177
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: The signal transfer tool doesn't work with colour light signals
« Reply #3 on: December 13, 2016, 11:21:15 PM »
Transferring individual signals now seems to work, but transferring all signals of a signalbox doesn't.

I think that I have found and fixed this - would you be able to re-test?
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.