Author Topic: Strange error  (Read 647 times)

0 Members and 1 Guest are viewing this topic.

Offline accord2

Strange error
« on: March 08, 2017, 04:12:41 PM »
I think it is related with signalling, since it only started when I started using signals in my railway.

https://www.dropbox.com/s/nu71wu8ohva2x7i/error.png?dl=0

I have no idea of why it appears. It shows up at diferent situations, when two trains go to the same platform, when a train reverses at the end of the line and sometimes when a train reaches an one train staff cabinet (those strange boxes). Maybe I am doing something wrong?

Offline Junna

Re: Strange error
« Reply #1 on: March 08, 2017, 05:31:11 PM »
Shouldn't crash either way. You should upload the save game at a time when it is about to happen for debugging.

Offline accord2

Re: Strange error
« Reply #2 on: March 08, 2017, 07:08:08 PM »
Shouldn't crash either way. You should upload the save game at a time when it is about to happen for debugging.
But I have no way of knowing when it happens :/

Offline Junna

Re: Strange error
« Reply #3 on: March 08, 2017, 07:14:06 PM »
Does it occur randomly, in what span of time? How frequently? Probably good to upload it anyway.

Offline jamespetts

  • Simitrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 15858
  • Total likes: 407
  • Helpful: 177
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Strange error
« Reply #4 on: March 08, 2017, 10:50:15 PM »
As Junna indicated, I will not be able to fix this without a means of reproducing it reliably. Could you upload a saved game in which this can reliably be reproduced? I should be grateful.
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

Offline accord2

Re: Strange error
« Reply #5 on: March 09, 2017, 03:18:24 PM »
https://www.dropbox.com/s/ybhdn234iqh7krf/Elsingstoke%2017.7.sve?dl=0

I don't know why it happens, so please put it in fast-forward and wait. I thought it was because I had two trains using the same line with a staff cabinet, but when I removed the second train it keep happening. Most possibly it is caused by the staff cabinet, but I am not sure.

Offline jamespetts

  • Simitrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 15858
  • Total likes: 407
  • Helpful: 177
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Strange error
« Reply #6 on: March 10, 2017, 01:14:46 AM »
I am afraid that I cannot reproduce this: I fast forwarded to November 1831 and it did not crash.
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.