The International Simutrans Forum

 

Author Topic: after 'server did not respond', can't join other server  (Read 1514 times)

0 Members and 1 Guest are viewing this topic.

Offline asaphxiix

  • *
  • Posts: 723
after 'server did not respond', can't join other server
« on: December 06, 2017, 06:17:46 PM »
if the server to which the attempted contact was made (by clicking it in the connection screen) isn't answering, the connection window will say 'server did not respond' even when another server (which is online) is clicked. Thus, one can only connect to the other server after restarting the client, and an unsuspecting player is likely to consider that both servers are down.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 17765
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: after 'server did not respond', can't join other server
« Reply #1 on: December 06, 2017, 07:44:22 PM »
The code for this is unchanged from Standard; can anyone confirm whether this can be reproduced in Standard?

Offline AP

  • Devotee
  • *
  • Posts: 1202
  • Languages: EN
Re: after 'server did not respond', can't join other server
« Reply #2 on: December 10, 2017, 05:35:40 PM »
I can confirm seeing the same behaviour in Extended.

Offline DrSuperGood

  • Dev Team
  • Devotee
  • *
  • Posts: 2525
  • Languages: EN
Re: after 'server did not respond', can't join other server
« Reply #3 on: December 10, 2017, 05:46:52 PM »
Yes this does effect standard as well. Ran into it when testing out my recent net code changes.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 17765
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: after 'server did not respond', can't join other server
« Reply #4 on: December 10, 2017, 09:51:19 PM »
I have moved this to the Standard bug reports section, as this can be reproduced in Standard.

Offline TurfIt

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 1309
Re: after 'server did not respond', can't join other server
« Reply #5 on: December 11, 2017, 09:00:34 PM »
r8350 appears to fix.  Was difficult to repro before, and can't now, so maybe...