News:

Simutrans Forum Archive
A complete record of the old Simutrans Forum.

[0.5] Bugs

Started by Emil Sawicki, December 24, 2017, 09:18:50 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Emil Sawicki

There are some bugs:
-no road bridges;
-only one road tunnel;
-no Schwebebahn depot, signals and stations;
-graphic artifacts in buildings:
--ind_cl5_E3_04_07;
--ind_cl5_E3_05_07.
Simutrans 120.2.2, Windows 10
facebook.com/SimutransPL
My screenshots

Flemmbrav

thanks a lot, didn't check everything. The first two "bugs" are just me failing go compile the pakset.
Also one depot for ships is bugged

I'll take a look at these 3 tonight

EDIT: i ninjafixed that. I don't see the downloads beeing high enuogh to make that a new V already. So if you have problems with network games, download a fresh pakset ;)

Emil Sawicki

There are still missing objects (eg. narrowgauge Bahnsteige). I found another bug: when using 0.5 it's unable to load game saved under 0.4.2.hH. Even after copying missing objects game is corrupted.
Simutrans 120.2.2, Windows 10
facebook.com/SimutransPL
My screenshots

Flemmbrav

Both features not bugs.
The stations ain't there anymore since they can't really compete. You can't load 0.4.2.hH saves for a really nice feature I forgot to put in the annouciation post. my bad haha.

Emil Sawicki

#4
The 20 ton bulk waggons are invisible when going south-west. They've also empty images when are loaded with coal (going south).
Simutrans 120.2.2, Windows 10
facebook.com/SimutransPL
My screenshots

Leartin

Thank you for the information, there were some troubles in the dat files in some coal wagons. For a quick fix, I linked the new wagons, which show graphics in all 8 directions.


https://www.dropbox.com/s/3wwyrajrr2oqzo6/coalwagons.rar?dl=0

Citarofahrer

Hi there

thanks for the awesome update!

BUT
if you load the large theme in pak192 style, you can't read the text ond buttons.

Cheers CF

Leartin

Oops, upload of the "large" theme was not intended, it's still the old theme file, but now with the new graphics used in the small theme.

At this time, I don't want to offer a dedicated "large" theme, as I feel like it would only make sense if
A) There was a way to have larger text, so it would actually help with giant monitors - or
B) There was an actual, community-endorsed mobile version of the game, which requires touchable buttons.

I don't have high hopes actually, since I don't think it has priority for any dev except perhaps An_dz, who was not here in a while.

Citarofahrer

Hi Leartin

thats my problem. i'm running Simutrans on 3(!) 4K Screens, so the Buttons are way to small xD

Leartin

My rule of thumb for a non-touch-monitor: If you can read it, you can click it. If you can't read it, there is no need to click it.

Anyway, attached is a large theme that is identical to the other theme, but with larger buttons and icons.

Violski

Hi,
thanks for the update! I am having some issues and I suppose some of them may relate to the new pakset because I did not experience them with the earlier version:

1. Bus stations near the town hall get a strange name, for example: "Starnberg tow_3_modern H"

2. Graphics seem to be confused - I see parks where there should be buildings, see the attached screenshot of a city with "buildings" that have 4 or 5 passengers. When I click on the buildings, it tells me it's a house but what I see is a labyrinth...

3. not sure whether this is related to the pakset, but I did not experience this with an earlier version: Passenger traffic in cities somehow stops at some point. I may have a functioning network between cities, but sometimes when I add additional lines that connect houses within a city to the town hall, all of a sudden passengers stop boarding busses or trams. They still wait in the bus stops, but the busses stay empty. I have tried a few things to find out what the problem might be but I couldn't figure it out. Anyone has had this problem? I couldn't find anything on this in the forum.

Leartin

Thank you for the feedback.

Quote from: Violski on January 07, 2018, 10:52:35 PM
1. Bus stations near the town hall get a strange name, for example: "Starnberg tow_3_modern H"

2. Graphics seem to be confused - I see parks where there should be buildings, see the attached screenshot of a city with "buildings" that have 4 or 5 passengers. When I click on the buildings, it tells me it's a house but what I see is a labyrinth...

Those are both due to lacking translation files. Stations take on the names of some buildings, like townhalls, factories and curiosities. "tow_3_modern" is the object name of the townhall, which did not get a translation.
Similarly, the game knows of industrial, commercial and residential buildings. Those have a general fallback-translation. The labyrinth park appears to have no translation of it's own, so it falls back to being a residential building instead.
Both issues are easy to fix, but it's not just those two objects, it's approximately a few hundred by now.

Quote from: Violski on January 07, 2018, 10:52:35 PM3. not sure whether this is related to the pakset, but I did not experience this with an earlier version: Passenger traffic in cities somehow stops at some point. I may have a functioning network between cities, but sometimes when I add additional lines that connect houses within a city to the town hall, all of a sudden passengers stop boarding busses or trams. They still wait in the bus stops, but the busses stay empty. I have tried a few things to find out what the problem might be but I couldn't figure it out. Anyone has had this problem? I couldn't find anything on this in the forum.
I'd suggest writing a more detailed report, perhaps with screenshots of the stops and vehicles - or even a savegame - in the Help Center. It's either a game bug or an unfortunate interaction of game settings and your playstyle, but probably not a pakset issue per se.

Suneo Wahyu Hidayat Hartanto

1. Track track to 1067mm usually we use 1435mm, initially I was shocked suddenly become 1067mm
2. Roads, bridges, rails, LAA (catenary), and soil structures are no longer sloping (unlike previous versions of very gentle slopes)
3. For power supply usage greater than previous version
4. Some changes to the goods code
Whyu

Leartin

For the gauge change, I even wrote about it in the indonesian facebook group before implementing it. Since indonesian trains use narrowgauge anyway, it's actually an improvement ;) - https://www.facebook.com/groups/simutransIndonesia/permalink/1941712832785007/

Slopes changed in this version. The previous 0.4 did not support half height as they did not exist in the game yet. That's how the game evolves - if there was no change, you could as well stick to 0.4.

Power supply usage... could be. Some factories use wrong numbers in their demand of pax, post and electricity. If it's that you are refering to, that will be fixed.

Changes to the goods code... Possibly, but nothing that's a bug (that I know of). The issue with renamed goods that keeps popping up in the indonesian facebook group is much, much older.

Suneo Wahyu Hidayat Hartanto


if the personal problems in pack 192 version 0.5.0 this, when I play simutrans, sometimes not responding and also sometimes nge-crash own game, I try to try the previous version 0.4.1 stable. what's the solution?
Whyu

Emil Sawicki

Paksets 0.4.x and 0.5 aren't compatible due to railways. If you updated previous version with the newest, you'll get crash.
Simutrans 120.2.2, Windows 10
facebook.com/SimutransPL
My screenshots

Suneo Wahyu Hidayat Hartanto

Quote from: Emil Sawicki on January 30, 2018, 05:05:10 AM
Paksets 0.4.x and 0.5 aren't compatible due to railways. If you updated previous version with the newest, you'll get crash.



I play simutrans with the latest version on my laptop, why always crash? in version 0.5.0 but in version 0.4.1 not crash? I try again for version 0.5.0 always crash? what's wrong?
Whyu

Flemmbrav

I play on r8163 with the 0.5 on win10 and do not experience crashes.

Which Simutrans revision do you use?

Suneo Wahyu Hidayat Hartanto

Quote from: Flemmbrav on January 31, 2018, 10:46:29 PM
I play on r8163 with the 0.5 on win10 and do not experience crashes.

Which  revision do you use?


i play on r8163 to with the 0.4.1 on win10.
Whyu

Flemmbrav

That's kind of the same setup I use. Can you post the error you get from starting the 0.5? (Screenshot would be great)

Suneo Wahyu Hidayat Hartanto

Quote from: Flemmbrav on February 02, 2018, 04:05:09 PM
That's kind of the same setup I use. Can you post the error you get from starting the 0.5? (Screenshot would be great)


when playing sometimes not responding
Whyu

Flemmbrav

That's a very vague bug describtion. It's not like I could search for it and fix it all, sorry.
Would be great to know some specifics about that.

Suneo Wahyu Hidayat Hartanto

i found a bug's again .. i play in map A with addons Indonesian. but, in map B, addons Indonesian no founded, besides addons indonesian
put it in the same folder, why?
Whyu

bigliettiperfavore

#23
Hi,
This might be a problem with my general settings... I am using the BR644 on some lines.
It does not seem to pick up all the passengers even if is heading in the direction of that given station. Happens on several lines, strange.
Attachments below:
1,2: station and train before arrival
3,4: station and train after departure


Love the work behind this btw.. excellent. :D

Edit: I have checked, it is happening to other vehicles as well.

Flemmbrav

You paly with no routing over overcrowded. ( A feature, not a bug)
Burgwedel and Eisleben are overcrowded. You either have to raise station capacity or carry the crowd away ;) .

ashwolf

Don't know if it's a bug (or a FEATURE) but nearly all the towns in the maps are named SIMCITY.

It makes it quite difficult to manage passengers lines without making mistakes...

Emil Sawicki

This is not a bug nor a feature. Just change their names manually or add citylist_xx.tab in your simutrans/pakset/text directory.
Simutrans 120.2.2, Windows 10
facebook.com/SimutransPL
My screenshots

Suneo Wahyu Hidayat Hartanto

I have a new problem, why every time I just open simutrans app and choose pakset 192, why after loading map he suddenly not responding so? any solutions? I use simutrans just like any other user here.
Whyu

Leartin

If it freezed after loading the map, it's most likely a problem with the map. Can you start a new map with the pakset? Is it a vanilla pakset and a vanilla map (no addons)?

Suneo Wahyu Hidayat Hartanto

the map I entered is a blank map, no vehicles, etc. the contents are only the names of cities and just as we started the game just now ...
Whyu