The International Simutrans Forum

 

Author Topic: Latest versions hang on 'second' passenger/mail network (WinXP/Virtual Machine).  (Read 753 times)

0 Members and 1 Guest are viewing this topic.

Offline Dutchman on Rails

  • *
  • Posts: 239
Hi James,

I have the same issue consistently recently. When setting up a mail service, all goes well, but when setting up another mail service (not connected to the first one), or a passengers service, after a while Simutrans-Ex stops responding and has to be killed. I'm not entirely sure, but this seems to happen on the first generation of passengers/Mail on the new network.

I've seen this problem occur on versions #468a1bd from last week as well as #d109f9e from yesterday evening. I'm using Windows XP 32bit on a VirtualBox virtual machine.

I'm afraid I can't do much in terms of troubleshooting, working out prices for the early locomotives (update coming tomorrow latest).

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Can you upload a saved game in which this issue can reliably be reproduced following a set of specific steps that you are able to specify?

Offline Dutchman on Rails

  • *
  • Posts: 239
Please find in the link two savegames.

https://simutrans-germany.com/files/upload/Hang_incident.zip

Load the first savegame and expand the network roughly similar to the situation in the second savegame. I've had two consecutive hangs with that. While reproducing the second hang, I generated the second savegame and on reloading that one I did not have a third hang. So it looks like I have a viable workaround.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
I do need a considerably more precise description of the exact sequence of individual steps to be able to reproduce something like this, as I need to know the exact point in the sequence at which the error occurs: there are a myriad different sequences of steps that can take one from one network state to another, much expanded network state.

Offline Dutchman on Rails

  • *
  • Posts: 239
Well, that's the point. While I used the same global method on the two expansion attempts (using the public service player to build the roads and stops, building the three lines in the order Saltnell, Ladstock, Steeple, I did not bother to build the infrastructure at exactly the same position. Also, the first hang was on April 10th, the second on April 18th.

I suppose we'll just have to wait until it shows up some other time. Now that I have a workaround it's becoming less of a priority anyway.