The International Simutrans Forum

 

Author Topic: [r8762] Minimap industry list labels have no colors  (Read 446 times)

0 Members and 1 Guest are viewing this topic.

Offline R1dO

  • *
  • Posts: 42
  • Languages: NL EN
[r8762] Minimap industry list labels have no colors
« on: May 30, 2019, 01:15:58 PM »
I just noticed that the labels on the industry list have no colors anymore.

I seem to remember they used to be colored corresponding to the icons on the map itself (which are still ok).

Since i build myself from source it is still possible something broke on my linux system, can someone confirm?

Using the following (relevant build parameters):
Code: [Select]
BACKEND = sdl2  # But happens with "sdl" as well
OSTYPE = linux
OPTIMISE = 1
MULTI_THREAD = 1

Offline Leartin at

  • Devotee
  • *
  • Posts: 1267
  • PAK-DEV P192C
  • Languages: DE, EN
Re: [r8762] Minimap industry list labels have no colors
« Reply #1 on: May 31, 2019, 05:35:46 AM »
While I'm not on the latest version, it's broken on windows too.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9561
  • Languages: De,EN,JP
Re: [r8762] Minimap industry list labels have no colors
« Reply #2 on: June 03, 2019, 05:04:29 AM »
Yes, a grey box was always draw after the correct one. Fixed in r8765.

Offline R1dO

  • *
  • Posts: 42
  • Languages: NL EN
Re: [r8762] Minimap industry list labels have no colors
« Reply #3 on: June 03, 2019, 05:44:53 PM »
Thank you for that.
I can confirm it works as expected now.