The International Simutrans Forum

 

Author Topic: relief map code refactor  (Read 360 times)

0 Members and 1 Guest are viewing this topic.

Offline ceeac

  • *
  • Posts: 45
relief map code refactor
« on: May 30, 2019, 07:04:31 AM »
This patch refactors reliefkarte_t and renames it to relief_map_t. Additionally, I renamed gui/karte.{h,cc} to gui/relief_map.{h,cc} .

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9514
  • Languages: De,EN,JP
Re: relief map code refactor
« Reply #1 on: June 03, 2019, 01:10:11 AM »
Since minimap is used for the overview map, maybe we should rather go there as a name? I.e. minimap_t

Offline ceeac

  • *
  • Posts: 45
Re: relief map code refactor
« Reply #2 on: June 30, 2019, 11:55:15 AM »
That makes sense. This would also solve any ambiguity with load_relief_frame_t.

Offline ceeac

  • *
  • Posts: 45
Re: relief map code refactor
« Reply #3 on: July 03, 2019, 07:00:46 AM »
Updated the patch: I renamed relief_map_t to minimap_t and updated the comments to reflect that.