The International Simutrans Forum

 

Author Topic: Requirement for high_clearance_uder_bridges ignored on open water  (Read 1119 times)

0 Members and 1 Guest are viewing this topic.

Offline Vladki

  • Devotee
  • *
  • Posts: 3338
    • My addons, mostly roadsigns, pak128.cs
  • Languages: EN, CS
In this save there are two low bridges (electric and road) over open water channel at 841,501.
http://list.extended.simutrans.org/debug-saves/bridges.sve
There is a Clyde puffer approaching the bridge from west and passes under just fine.
However if you build a low bridge over channel at 855,482 - ship will stop at the bridge and say "no route"

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 19824
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Requirement for high_clearance_uder_bridges ignored on open water
« Reply #1 on: January 18, 2020, 01:47:07 AM »
Thank you for the report: I believe that I have now fixed this . I should be grateful if you could re-test and confirm with the next nightly build.

Offline Freahk

  • Devotee
  • *
  • Posts: 1074
  • Languages: DE, EN
Re: Requirement for high_clearance_uder_bridges ignored on open water
« Reply #2 on: January 18, 2020, 02:47:21 AM »
I believe that I have now fixed this
:O This will break my map! xD

Offline Vladki

  • Devotee
  • *
  • Posts: 3338
    • My addons, mostly roadsigns, pak128.cs
  • Languages: EN, CS
Re: Requirement for high_clearance_uder_bridges ignored on open water
« Reply #3 on: January 18, 2020, 01:51:12 PM »
:O This will break my map! xD
Oh yes, it broke oil barge line on stephenson siemens server.

So there is now problem that no ships are allowed under low bridges. Oil barge does not have the requirement for high bridge, yet it cannot pass

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 19824
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Requirement for high_clearance_uder_bridges ignored on open water
« Reply #4 on: January 18, 2020, 02:13:08 PM »
Oh yes, it broke oil barge line on stephenson siemens server.

So there is now problem that no ships are allowed under low bridges. Oil barge does not have the requirement for high bridge, yet it cannot pass

Thank you for the report - I believe that I have also now fixed this. I should be grateful if you could re-test with the next nightly build.

Offline Vladki

  • Devotee
  • *
  • Posts: 3338
    • My addons, mostly roadsigns, pak128.cs
  • Languages: EN, CS
Re: Requirement for high_clearance_uder_bridges ignored on open water
« Reply #5 on: January 19, 2020, 06:16:36 PM »
Thanks, now it works as expected

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 19824
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Requirement for high_clearance_uder_bridges ignored on open water
« Reply #6 on: January 19, 2020, 07:48:17 PM »
Splendid, thank you for confirming.