The International Simutrans Forum

 

Author Topic: [120.4/r8588] "ignore climate" does not work when creating a city chain.  (Read 819 times)

0 Members and 1 Guest are viewing this topic.

Offline iGi

  • *
  • Posts: 1
  • Languages: EN, DE
When you want to place a city industry chain, the "ignore climate" option does not work. It works when you want to place a land industry chain.

Steps to reproduce:
I used pak128.german, but probably similar in other paks.
- Start new game
- switch to public player and open map editor toolbar and select "build industries". (not sure how it's called in english exactly...)
- you will see a similar window as in the attachment.
- select "all climates" and "city industry chain", try to build an industry in a climate where it doesn't belong to.  -> it will not work

switch to land industry chain and try the same, it works. Is there a reason why this shouldn't work?

Here you can see, the last parameter of the function is always false.
https://github.com/aburch/simutrans/blob/a0bdb53917cd2cba0a2f7c16afcb740b5b99bd3e/simtool.cc#L5545

the land chain will pass ignore_climate.
https://github.com/aburch/simutrans/blob/a0bdb53917cd2cba0a2f7c16afcb740b5b99bd3e/simtool.cc#L5477

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4620
  • Languages: EN, DE, AT
Re: [120.4/r8588] "ignore climate" does not work when creating a city chain.
« Reply #1 on: September 15, 2019, 12:55:54 PM »
thanks for the report, should be fixed in r8815.