The International Simutrans Forum

 

Author Topic: chat windows steal focus from message centre  (Read 291 times)

0 Members and 1 Guest are viewing this topic.

Offline Vladki cz

  • Devotee
  • *
  • Posts: 2906
    • My addons, mostly roadsigns, pak128.cs
  • Languages: EN, CS
chat windows steal focus from message centre
« on: December 17, 2019, 09:07:04 PM »
I noticed this in online game of simutrans-extended, but I think that the chat code is unmodified so this should apply to both versions.

When I send or receive a message it pops-up in dialog window and steals the focus. Further keystrokes then are interpreted as commands, potentially doing unwanted stuff.  I tried to set chat messages to not pop-up, but only run in the ticker, but they still pop-up.

So first bug - they pop-up all the time,
Second bug - would it be possible to make those windows not getting focus?

Offline Freahk

  • *
  • Posts: 577
  • Languages: DE, EN
Re: chat windows steal focus from message centre
« Reply #1 on: December 17, 2019, 10:54:34 PM »
As you was not sure about standard, I just want to confirm this for standard 212.0 r8870

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4620
  • Languages: EN, DE, AT
Re: chat windows steal focus from message centre
« Reply #2 on: December 18, 2019, 06:34:49 AM »
The focus-stealing is reproducible. However, I cannot reproduce the popup-part.

Offline Freahk

  • *
  • Posts: 577
  • Languages: DE, EN
Re: chat windows steal focus from message centre
« Reply #3 on: December 18, 2019, 09:46:30 AM »
The popup depends on the message centre options, it's not really part of the bug.
Open message centre options, tick the "transistent-" or "non-transistent  dialogue box "checkbox in the "chat" line and there you go.

Offline Vladki cz

  • Devotee
  • *
  • Posts: 2906
    • My addons, mostly roadsigns, pak128.cs
  • Languages: EN, CS
Re: chat windows steal focus from message centre
« Reply #4 on: December 18, 2019, 02:39:43 PM »
The popup depends on the message centre options, it's not really part of the bug.
Open message centre options, tick the "transistent-" or "non-transistent  dialogue box "checkbox in the "chat" line and there you go.

I did that (unticked them), but chat messages still pop-up. Maybe this part of bug is present only in extended...