The International Simutrans Forum

 

Author Topic: [BUG]? Choose signal sends train to occupied platform  (Read 421 times)

0 Members and 1 Guest are viewing this topic.

Offline Matthew

  • *
  • Posts: 386
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
[BUG]? Choose signal sends train to occupied platform
« on: January 19, 2020, 09:47:51 AM »
I have seen a choose signal send to a train to an occupied platform, even though an unoccupied platform is available. It may well be because there is something wrong with my signalling layout  :-[, but I thought that this might be helpful feedback since you (James) changed the Choose Signal code yesterday.

I was originally playing this game with a modded executable (last night's community version, but with Ranran's recent improvements added). But it reproduces in exactly the same way with last night's nightly (#b4e7900).

Steps to reproduce:
1. Create a new pakset directory to make sure that you don't mess up your normal pakset:
  • In Windows, create a pakset directory called Pak128.Britain-Ex-235 and copy the nightly pakset into it.
  • In Linux, create a symbolic link to your nightly pakset, called Pak128.Britain-Ex-235.
2. In both cases, download my addons from here and unpack the file into your Addons folder.
3. Download this save and put it into your saves directory.
4. Start Simutrans-Extended with the 235 pakset and addons.
Quote from: Troubleshooting
If Sim-Ex crashes, it is probably because the addons have not loaded due to a separate issue. Check whether with_private_paks = 1 in \Pak128.Britain-Ex-235\config\simuconf.tab. In Linux, this may require you to replace the symbolic link with a complete copy of the Pak128.Britain-Ex pakset.  ::'(
5. Load "Choose signal to occupied platform.sve".
6. Follow train 1309.
7. At approximately 00:22, the choose signal at (221,991,0) will send convoy 1309 to the far platform at Little Garelock Dock, which is already occupied by convoy 2326.

Offline Matthew

  • *
  • Posts: 386
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Re: [BUG]? Choose signal sends train to occupied platform
« Reply #1 on: January 23, 2020, 01:51:24 PM »
I have discovered that the cause of this was an error that I made in my signalling layout. The signal before the Choose Signal was a station signal. I apologize for wasting your time, James.

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 20207
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [BUG]? Choose signal sends train to occupied platform
« Reply #2 on: January 23, 2020, 05:47:54 PM »
Thank you for re-checking this, and do not worry about wasting my time: as it happens, I do not believe that I had got around to looking into this.