News:

Use the "Forum Search"
It may help you to find anything in the forum ;).

Bug: Unable to load pak128 Britain/Sweden. Crash during load.

Started by DrSuperGood, January 31, 2020, 06:27:04 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

DrSuperGood

Updated to nightly update using the tool. Choose pak128 Britain. Simutrans Extended crashes during the pakset load.

This applies to both pak128 Britain and Sweden. Same error during pakset loading. I tried re-downloading pak128 Britain and it did not help, still crashes with same error.

This does not apply to pak256 Japan. That loads perfectly and gets to the main menu.

Ranran(Hibernating)

The pak file version that the reader can read and the version generated by makeobj seem to be different, but this did not happen with my own build. Where is this difference...  ???

EDIT: I am currently investigating Vehicle reader. I may not have modified the version correctly
(´・ω・`)シミュトランスのアップデート履歴(日本語) (※更新停止中)
bit.ly/3AuKHHP

CK


I'm getting the same error. The nightly updater did download a lot of pak files which hadn't been changed for 2 years on Github, so perhaps something went wrong during (re)compilation?

update:
Simutrans version 120.2.1 Extended Nightly development build 14.7 from Jan 30 2020 #13b2849
Preparing display ...
modal_dialogue( sel, magic_none, NULL, empty_objfilename );
parse_simuconf() at Pak128.Britain-Ex/config\simuconf.tab:
Reading compatibility sound data ...
Reading city configuration ...
Reading electricity consumption configuration ...
Reading menu configuration ...
Reading object data from Pak128.Britain-Ex/...
FATAL ERROR: vehicle_reader_t::read_node() - Incompatible pak file version for Simutrans-Ex, number 5
Aborting program execution ...

For help with this error or to file a bug report please see the Simutrans forum at
http://forum.simutrans.com

The logfile isn't exactly informative either.

jamespetts

This was caused by a compile error on Linux in the main executable, meaning that only the earlier version of the executable was available. Because makeobj had changed and because makeobj was not affected by this error, the pakset version was ahead of the code version and would thus not open.

I have now applied a fix to that prepared by Freddy and am running an emergency re-compile on the server, so the updated version should be available in a few minutes.
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

jamespetts

The recompile has now been completed, so downloads from the server should now work.
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

Ranran(Hibernating)

(´・ω・`)シミュトランスのアップデート履歴(日本語) (※更新停止中)
bit.ly/3AuKHHP