The International Simutrans Forum

 

Author Topic: Private car routing calculation may performed even if they are eradicated  (Read 273 times)

0 Members and 1 Guest are viewing this topic.

Offline Ranran

  • Devotee
  • *
  • Posts: 1503
  • Languages: ja
Possibility that private car routing calculation is performed even if the city car is eradicated (very high CPU load)


Although james has suggested that setting assume_everywhere_connected_by_road = 1 disables private car routing, if it is disabled then no routing calculations should be done.
I disabled it, but noticed that the game's CPU load was very high.
It seems that the routing process is being performed according to the setting of "max_route_tiles_to_process_in_a_step".


Observation procedure regarding this:
1) set assume_everywhere_connected_by_road to 1 in Britain-Ex folder's simuconf.tab. This should eliminate the need for the private car routing process anymore.
     Also check if max_route_tiles_to_process_in_a_step is the default 1024.
2) Create a new map. Please increase the number of cities and populations, and create a modern city with more city cars.
3) Observe the CPU load rate. Also check the fast-forward speed.
4) Please change so that the setting of simuconf.tab is overwritten - rewrite pak_overrides_savegame_settings = 1 in extended install folder's simuconf.tab.
    If you don't understand how to do 4), skip 4) and create a new map to check the changes caused by your configuration changes.
5) Change max_route_tiles_to_process_in_a_step in Britain-Ex folder's simuconf.tab to 0 or 65535.
6) Load the map in 2) or create a new map.
7) Observe the CPU load rate. Also check the fast-forward speed.
8 ) You will observe a very high load.
9) Change citycar_level in Britain-Ex folder's simuconf.tab to 0 and max_route_tiles_to_process_in_a_step to 1024.
10) Create a new map. No citycar is born on that map.
11) Observe the CPU load rate. Also check the fast-forward speed.
12) Change max_route_tiles_to_process_in_a_step in Britain-Ex folder's simuconf.tab to 0 or 65535.
13) Create a new map. No citycar is born on that map.
14) Observe the CPU load rate. Also check the fast-forward speed.
15) delete (or move to other folder) citycar.*.pak from Pak128.Britain-Ex folder
16) Repeat steps 9)-14).



Also max_route_tiles_to_process_in_a_step seems to be closely involved in desync. The larger this value, the shorter the time to desync. For example, with 0 or 65535, it is difficult to connect for 1 minute. On the other hand, setting it to 1 seems to make the connection stable. As you can deduce from the above experiment, it is the same if you eradicate the citycar.
Please note that these are tests on loaclhost. The CPU load becomes very high, so specifications may be involved.

Anyway I've tried every means to disable the private car routing feature, but it doesn't seem to be possible.
« Last Edit: May 01, 2020, 04:14:49 PM by Ranran »

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Administrator
  • *
  • Posts: 20768
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Thank you for spotting this. I believe that I have now fixed this; I should be grateful if you could re-test with to-morrow's nightly build.