The International Simutrans Forum

 

Author Topic: Map builds strangely when starting new game  (Read 1527 times)

0 Members and 1 Guest are viewing this topic.

nogitsune

  • Guest
Map builds strangely when starting new game
« on: April 26, 2009, 04:44:51 PM »
I found the problem hard to summarise in the title...

I am using the 102 Windows version of Simutrans, and I've tried this with both the SDL and the non-SDL version, as well as with a number of different paks, all with the same result:

When I generate a new map for a new game, the game generates a flat snowy plain almost completely without any features on it. Occasionally there is an industry somewhere, but nothing else. There are trees and lighthouses, but they are clustered in little groups and only appear on the slopes down to the water at the outer edges of the map.

The above is if I generate a map with the settings exactly as they are with the game right out of the archive straight from the download site.

If I fiddle a little with the settings, I either get the exact same result or the game hangs on map generation. If I fiddle a lot with the settings the game hangs on map generation.

I don't see anyone else with this problem, so obviously it's something on my machine, but what could it possibly be?

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Administrator
  • *
  • Posts: 20917
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Map builds strangely when starting new game
« Reply #1 on: April 26, 2009, 04:50:09 PM »
Hmm, that's very odd. Are you using the stable build or the nightly versions? If you are using the stable build, try the latest nightly version. If you are using a nightly version, can you give us the version number?

nogitsune

  • Guest
Re: Map builds strangely when starting new game
« Reply #2 on: April 26, 2009, 05:30:47 PM »
I'm using the "latest official release" off the download page on simutrans.com. It's labeled as 102-0 if that's any help. I'm going to try a nightly build and get back to you on the results.

EDIT: Where do I find it? Or for that matter the latest stable release so I can try that? I keep hitting only dead links for downloads...

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Administrator
  • *
  • Posts: 20917
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Map builds strangely when starting new game
« Reply #3 on: April 26, 2009, 06:45:36 PM »
Ahh, simutrans-germany.com appears to be down at present. When that's working again, you should be able to download the latest nightly.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4898
  • Languages: EN, DE, AT
Re: Map builds strangely when starting new game
« Reply #4 on: April 26, 2009, 07:11:35 PM »