News:

The Forum Rules and Guidelines
Our forum has Rules and Guidelines. Please, be kind and read them ;).

How can i compile ST and Makeobj on Linux Mint?

Started by NNW, June 10, 2020, 03:30:59 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

NNW

Could someone please explain me step by step what do I need besides the sources of ST on Github, respectively what parameters should i exactly put in the config.default?
Also, why do i no longer need ./configure?

Thank you

prissi

There is configure, but it is built by autoconf.

autoconf
./configure
make

should work.

For libraries, you need at least libSDL2-devel, libz-devel, and lingpng (for makeobj). The revisioning need SVN, so you may need to install a subversion client.

You can look at the github action script (in .githaub/workflows/nightly-ubuntu.yml) to compile on Linux, since this installs all needed librariers. It is Debian/Ubuntu, but adapting for Mint should be straight forward. See blow

        # set up dependencies
        sudo apt-get -y update
        sudo apt-get -ym install libsdl2-dev
        sudo apt-get -ym install libfreetype6-dev
        sudo apt-get -ym install libminiupnpc-dev
        sudo apt-get -ym install libbz2-dev
        sudo apt-get -ym install autoconf
        # now build simutrans
        autoconf
        ./configure
        echo "FLAGS = -DREVISION=$(svn info --show-item revision svn://servers.simutrans.org/simutrans) " >>config.default
        echo "STATIC = 1" >>config.default
        make install
        # download translations
        sh ./distribute.sh
        # now you have a zip file and a full simutrans folder



Andarix

Quote from: prissi on June 11, 2020, 11:42:52 AM
...
For libraries, you need at least libSDL2-devel, libz-devel, and lingpng (for makeobj). The revisioning need SVN, so you may need to install a subversion client.
....

libbz2-devel

and the revision can set in config.default

CFLAGS  += -DREVISION="9124"

for makeobj you have to run make in the trunk/makeobj folder