The International Simutrans Forum

 

Author Topic: Duplicate departures bug  (Read 143 times)

0 Members and 1 Guest are viewing this topic.

Offline freddyhayward

  • Devotee
  • *
  • Posts: 224
  • Languages: EN
Duplicate departures bug
« on: June 19, 2020, 08:17:26 AM »
Sometimes, two vehicles on a line take up two schedule slots. This affects rail and water vehicles, but the attached example uses buses.


Offline jamespetts

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 19823
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Duplicate departures bug
« Reply #1 on: June 19, 2020, 10:20:17 AM »
Thank you for that. The problem in question will occur when the second 'bus that ends up being assigned the same departure slot as an existing 'bus arrives. Is there a known time in the future after loading this saved game at which this occurs? I am not likely to be able to diagnose the problem from seeing that there are already two with the same slot.

Offline freddyhayward

  • Devotee
  • *
  • Posts: 224
  • Languages: EN
Re: Duplicate departures bug
« Reply #2 on: June 19, 2020, 10:34:08 AM »
Is there a known time in the future after loading this saved game at which this occurs?
As I tried to show with the graph, an extra departure occurs about once every second scheduled departure, at least in this save. However, you could reproduce the problem from the beginning by withdrawing all the covoys from the line and sending out 8 new ones.

Offline Sarrus

  • *
  • Posts: 54
  • Languages: EN, PL
Re: Duplicate departures bug
« Reply #3 on: June 30, 2020, 09:13:29 AM »
I experienced this issue on one of my lines. I have no more information for you, but I will post here if I will have anything more than "it happens sometimes".

EDIT:

I noticed that sometimes trains follow it's schedule in reverse order. I attached screenshots of trains going one after another from Pudstone Station. There was that duplicate departure issue happened.

EDIT2:
Oh and that line had "Mirror schedule" earlier. I resigned from that feature for correct platform choosing. When I noticed that schedule issue, I thought it is a bug, so I deleted line and recreated from scratch. It wasn't help.
« Last Edit: June 30, 2020, 12:30:42 PM by Sarrus »