News:

Simutrans.com Portal
Our Simutrans site. You can find everything about Simutrans from here.

Forum forces me to use Albanian

Started by Ranran(Hibernating), June 25, 2020, 11:17:16 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Ranran(Hibernating)

The forum has begun to force me to use Albanian today.  (´・ω・`)

While I am decoding Albanian and managed to get to the settings page and try to change the language to English.
But in this way the language change is rejected.


But I don't know what it says. Dr. Google translate blindly sees that part, and I can't type it.
Please help me. (´・ω・`)
(´・ω・`)シミュトランスのアップデート履歴(日本語) (※更新停止中)
bit.ly/3AuKHHP

freddyhayward

I have also experienced this issue, although it doesn't seem to occur in debug builds. I suspect this was caused by a change in the translation code in the latest patch. However, the rest of the code is so old and complicated that the underlying bug might never be fixed unless the entire patch is reverted, which is not currently viable. Instead, I have already started learning Albanian, and I recommend you do too.

Leartin

Everything works as intended.

One of the boons of being a Devotee. Well, there really is no problem though. The forum just wants you to enter your password to change the language, for security reasons. Imagine what could happen if you accidentially changed your language to one you don't understand... smart move of the forum

makie

It is not a bug, it is a feature for learning foreign languages.  ;D
IBM: It is not a bug, the system works a designed.

Ranran(Hibernating)

The problem was that when I visited the forum again today everything was changed to Albanian although I didn't set it to Albanian.
I couldn't understand what I needed because I couldn't read Albanian. It was solved by setting a password. Thank you for your advice.
(´・ω・`)シミュトランスのアップデート履歴(日本語) (※更新停止中)
bit.ly/3AuKHHP