The International Simutrans Forum

 

Author Topic: Pinning a post for the Chinese forum  (Read 471 times)

0 Members and 1 Guest are viewing this topic.

Offline Matthew

  • *
  • Posts: 384
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Pinning a post for the Chinese forum
« on: July 31, 2020, 02:28:04 AM »
I discovered yesterday that if you try to edit a post containing Chinese characters, they get converted into unreadable code points.  ???

For future reference, this page can undo the damage provided you remove all ASCII characters: https://onlineutf8tools.com/convert-code-points-to-utf8

It would be a waste of time trying to fix this given how little traffic the Chinese forum gets, but if I create a warning post, would a mod be willing to pin it to the top of that forum?

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10124
  • Languages: De,EN,JP
Re: Pinning a post for the Chinese forum
« Reply #1 on: July 31, 2020, 03:16:20 AM »
I am somehow surprise because I can enter Japanese on a western windows and the input get converted to UTF8. Same for editing my posts. Maybe this is tied to a specific setting/environment.
edit: (with button) I can enter Kanji 漢字
« Last Edit: August 03, 2020, 03:19:54 AM by prissi »

Offline Matthew

  • *
  • Posts: 384
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Re: Pinning a post for the Chinese forum
« Reply #2 on: July 31, 2020, 03:35:10 AM »
EN: That's interesting. Let's test editing this post.
I changed it.

ZH: %u5F88%u6709%u610F%u601D%u3002%u5B9E%u9A8C%u7F16%u8F91%u672C%u5E16%u5B50%u5427%u3002
%u6539%u53D8%u4E86%u3002

Offline Matthew

  • *
  • Posts: 384
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Re: Pinning a post for the Chinese forum
« Reply #3 on: July 31, 2020, 03:40:37 AM »
EN: That post was on Linux. What's editing on Windows like?
Test: Simutrans is great.

ZH: %u4E0A%u9762%u7684%u5E16%u5B50%u4F7F%u7528Linux%u3002%u5728Windows%u7F16%u8F91%u600E%u4E48%u6837%uFF1F
%u5B9E%u9A8C%uFF1ASimutrans%u592A%u68D2%u4E86%u3002

Offline Matthew

  • *
  • Posts: 384
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Re: Pinning a post for the Chinese forum
« Reply #4 on: July 31, 2020, 03:46:09 AM »
EN: Does Edge improve the situation?
Test: The forum is poorly.

ZH: %u4F7F%u7528Edge%u7684%u8BDD%uFF0C%u60C5%u51B5%u8FDB%u6B65%u6CA1%u6709%uFF1F
%u5B9E%u9A8C%uFF1A%u8BBA%u533A%u75C5%u4E86%u3002

EN: So you can see that I get the same results on Firefox in Linux (iBus Intelligent Pinyin) and both Firefox and Edge on Windows 10 (Microsoft IME). The initial post is OK, the text shows up in the Modify box, but when I hit save it is converted into code points.

Prissi, may I ask how you are entering Japanese?

Offline Isaac Eiland-Hall

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3823
  • Providing hosting for Simutrans projects
    • pc2.io
  • Languages: EN
Re: Pinning a post for the Chinese forum
« Reply #5 on: July 31, 2020, 11:28:44 PM »
A while back, I tried to input the "look of disapproval" which uses Kannada characters, which had the same results - although others were able to enter them.

I'm not smart enough on the topic of encoding to know why this is, frankly.

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2920
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: Pinning a post for the Chinese forum
« Reply #6 on: August 01, 2020, 07:09:24 PM »
It could have some link with using the WYSIWYG editor versus the plain text version.

Offline Freahk

  • Devotee
  • *
  • Posts: 1244
  • Languages: DE, EN
Re: Pinning a post for the Chinese forum
« Reply #7 on: August 01, 2020, 07:17:22 PM »
There is a WYSIWYG editor?

Offline Isaac Eiland-Hall

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3823
  • Providing hosting for Simutrans projects
    • pc2.io
  • Languages: EN
Re: Pinning a post for the Chinese forum
« Reply #8 on: August 02, 2020, 05:53:53 AM »
There is a WYSIWYG editor?

When you "Reply" (using the button, not the quick reply at the bottom), look for and click to toggle text/visual editing.

( https://ieh.im/i/200802-015255.png )

Offline Matthew

  • *
  • Posts: 384
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Re: Pinning a post for the Chinese forum
« Reply #9 on: August 02, 2020, 06:27:43 AM »
When you "Reply" (using the button, not the quick reply at the bottom), look for and click to toggle text/visual editing.

( https://ieh.im/i/200802-015255.png )
EN: TIL! Let's give this a test then. (Firefox, Linux, iBus Intelligent Pinyin)
Can we modify this way?

ZH: %u4ECA%u5929%u6211%u5B66%u5230%uFF01%u54B1%u4EEC%u8BD5%u4E00%u8BD5%u5427%u3002
%u54B1%u4EEC%u80FD%u4E0D%u80FD%u8FD9%u6837%u7F16%u8F91 %uFF1F

Offline Matthew

  • *
  • Posts: 384
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Re: Pinning a post for the Chinese forum
« Reply #10 on: August 02, 2020, 06:32:18 AM »
EN: Maybe we are required to use the top Modify button?Another test.

ZH: 说不定必须使用上面的编辑按钮吧?在来一个实验。

Success!!!  :done: The answer is: to preserve Chinese characters, you must use the Modify button at the top of the post (the one that loads a new page), not the one at the bottom of the post (that allows you to edit in-place).  ??? :::)

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10124
  • Languages: De,EN,JP
Re: Pinning a post for the Chinese forum
« Reply #11 on: August 03, 2020, 03:21:13 AM »
I did not even know that there is another button. But using this button, I cannot edit anything. I just says"Text is empty", whenver there is a character above 127. Even German Umlaute do not work with this button.