The International Simutrans Forum

 

Author Topic: Castle class tender cannot be inserted in depot  (Read 277 times)

0 Members and 1 Guest are viewing this topic.

Offline Matthew

  • *
  • Posts: 439
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Castle class tender cannot be inserted in depot
« on: November 03, 2020, 06:24:44 PM »
When I use Insert mode in a railway depot in front of GWR carriages, the Castle class tender does not appear, so I cannot switch the train's locomotive to Castle class. The standard "GWR tender" and the "3000g tender" appear, but not the Castle class one. Does anyone know why this happens?

Steps to reproduce:

1. Create a new map in 1930.
2. Build a railway with a depot.
3. In the depot, Append a GWR locomotive (tank or tender engines are both acceptable) and GWR carriages.
4. Remove the locomotive by clicking on it.
5. Change the mode from Append to Insert.
6. Various tenders will appear. The Castle class tender does not appear.

I compared the Castle class tender's .dat file with the other tenders of that era, but I could not see any difference that would explain this. However, I do not understand the vehicle recombination rules very well.

Offline jonbridg

  • *
  • Posts: 75
  • Languages: EN
Re: Castle class tender cannot be inserted in depot
« Reply #1 on: November 07, 2020, 12:56:48 AM »
I've just had a look at this myself and notice that tenders are missing for several other classes in Put in front mode, and not limited to GWR classes. Too late to do any more detective work now but I'll take another look tomorrow.

Offline Matthew

  • *
  • Posts: 439
    • Japan Railway Journal
  • Languages: EN, some ZH, DE & SQ
Re: Castle class tender cannot be inserted in depot
« Reply #2 on: November 07, 2020, 11:38:02 AM »
I've just had a look at this myself and notice that tenders are missing for several other classes in Put in front mode, and not limited to GWR classes. Too late to do any more detective work now but I'll take another look tomorrow.

Thank you! You have more experience with vehicle combination code, so hopefully what is a mystery to me will be elementary to you.

Offline jonbridg

  • *
  • Posts: 75
  • Languages: EN
Re: Castle class tender cannot be inserted in depot
« Reply #3 on: November 22, 2020, 11:32:56 AM »
so hopefully what is a mystery to me will be elementary to you.
I don't know about xD

Had another look at this issue this morning; there seems to be a definite link between whether the tender is visible in the put in front menu, and whether the tender can be used with multiple locomotives, eg. in January 1956:
The BR standard tender (49t version) can be used with a 7MT Britannia or an 8P, and is visible.
The BR 9F tender can only be used with a 9F, and is not visible.

There was at least one exception, IIRC the GWR Duke tender, but there was nothing obviously different in the dat file.

It will be worth seeing if the newer constraint code solves the issue. Does anyone more familiar with the constraints code understand why the above might occur?