The International Simutrans Forum

 

Author Topic: Powerplant construction  (Read 546 times)

0 Members and 1 Guest are viewing this topic.

Offline Jurien72

  • *
  • Posts: 2
  • Languages: English
Powerplant construction
« on: December 31, 2020, 09:54:06 PM »
Hello everyone! I'm trying to design an add-on for a powerplant, but I can't seem to find any specific information about how to set up the dat file. I can find info about factories but not powerplants/electricity production. When I try to create one, it comes up in the game as an electricity consumer, not a producer. Any clues as to what I'm doing wrong? Thanks!

Offline Leartin

  • Oh no, not him again!
  • Devotee
  • *
  • Posts: 1578
  • PAK-DEV P192C
  • Languages: DE, EN
Re: Powerplant construction
« Reply #1 on: December 31, 2020, 10:10:00 PM »
To get a working powerplant:
It's name must end in 'kraftwerk' (I think 'powerplant' works too, but most powerplants still use the kraftwerk name)
It cannot have electricity_amount or electricity_boost Scratch that, It can have those, but I think it messes with factory spawner (how many powerplants in comparison to other factories are needed), there was some issue like that.
It cannot produce any goods (eg. a nuclear power plant that also produces nuclear waste is not possible)

Offline Jurien72

  • *
  • Posts: 2
  • Languages: English
Re: Powerplant construction
« Reply #2 on: December 31, 2020, 10:33:49 PM »
To get a working powerplant:
It's name must end in 'kraftwerk' (I think 'powerplant' works too, but most powerplants still use the kraftwerk name)
It cannot have electricity_amount or electricity_boost Scratch that, It can have those, but I think it messes with factory spawner (how many powerplants in comparison to other factories are needed), there was some issue like that.
It cannot produce any goods (eg. a nuclear power plant that also produces nuclear waste is not possible)
Ahh! I think that may be my problem. I'm basically just playing around with the pak128 source files, and I think I just added a "2" on the end of the name. I will try your suggestion and see if that's the problem. There are differences between the older powerplants and the newer ones in terms of the entries in the .dat file, which is why I was asking if there is some documentation on their functions.

Thanks for the help!