The International Simutrans Forum

 

Author Topic: Simutrans from the DEB Repo crashes with LM 20.1  (Read 733 times)

0 Members and 1 Guest are viewing this topic.

Offline NNW

  • *
  • Posts: 90
  • Languages: EN,DE,AT
Simutrans from the DEB Repo crashes with LM 20.1
« on: January 15, 2021, 10:24:13 AM »
Hello
I have "updated" my Desktop system vom Linux Mint 19.3 Tricia to 20.1 Ulyssa and reinstalled ST from the Simutrans-uni Repo. I tried to start it, but it crashes with a memory access violation. So I tried the simutrans-sdl2 Version and that works.
I thought you should know that. Maybe it will help if someone else comes with this problem.
System Crash report

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4931
  • Languages: EN, DE, AT
Re: Simutrans from the DEB Repo crashes with LM 20.1
« Reply #1 on: January 15, 2021, 12:12:52 PM »
Do you have any idea, which version of simutrans comes with this system? Did this happen with a particular savegame?

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10979
  • Languages: De,EN,JP
Re: Simutrans from the DEB Repo crashes with LM 20.1
« Reply #2 on: January 15, 2021, 01:02:43 PM »
COuld be the problem with the libzstd, since extended xompiled under Ubuntu 20.04 had also problems.

Offline Andarix

  • *
  • Posts: 336
  • Languages: de
Re: Simutrans from the DEB Repo crashes with LM 20.1
« Reply #3 on: January 15, 2021, 02:04:02 PM »
Ubuntu 20.04 and SDL_mixer/SDL2_mixer not work.

The Simutrans version from the distribution repo doesn't work either.

As a result, mixer does not work with all derived distributions either.

There are already several reports about this.

This is also on the repo page in the wiki.
repo page german
english page comments
« Last Edit: January 15, 2021, 02:20:37 PM by Andarix »

Offline NNW

  • *
  • Posts: 90
  • Languages: EN,DE,AT
Re: Simutrans from the DEB Repo crashes with LM 20.1
« Reply #4 on: January 16, 2021, 09:30:26 AM »
Quote
As a result, mixer does not work with all derived distributions either.

There are already several reports about this.

You know the problem.Fine. And what can be done to prevent it?
t would be a real pity if I could no longer use ST because my Distri is "too advanced" for it. Because I then would have to stop working on PAK128.german as well.
Quote
Ubuntu 20.04 and SDL_mixer/SDL2_mixer not work.

SDL2 works.

Offline Andarix

  • *
  • Posts: 336
  • Languages: de
Re: Simutrans from the DEB Repo crashes with LM 20.1
« Reply #5 on: January 16, 2021, 10:03:52 AM »
...
SDL2 works.

SDL2 is not SDL2_mixer

The question is, what has changed Debian/Ubuntu that SDL2_mixer does not work anymore. Or is it a problem with SDL2_mixer.

As long as SDL2 works, this is not a fundamental problem for Simutrans itself.

Offline NNW

  • *
  • Posts: 90
  • Languages: EN,DE,AT
Re: Simutrans from the DEB Repo crashes with LM 20.1
« Reply #6 on: January 17, 2021, 09:22:07 AM »
Ok  ;D
The main thing is that ST works.
It is, together with Factorio and Satisfactory one of my favourite games