The International Simutrans Forum

 

Author Topic: Mark 1 BG has the wrong top speed  (Read 193 times)

0 Members and 1 Guest are viewing this topic.

Offline Rollmaterial

  • Devotee
  • *
  • Posts: 621
  • OS: Windows 10
  • Languages: EN, FR, DE, FI, SE
Mark 1 BG has the wrong top speed
« on: January 24, 2021, 12:40:00 AM »
The Mark 1 BG currently has a top speed of 100 mph. I have raised it to 110 mph in this commit: https://github.com/jamespetts/simutrans-pak128.britain/pull/112

Source for the change: https://en.wikipedia.org/wiki/Brake_Gangwayed

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Administrator
  • *
  • Posts: 20715
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Mark 1 BG has the wrong top speed
« Reply #1 on: January 24, 2021, 11:47:00 AM »
Thank you - now incorporated.

In reality, things were a little more complex, as the vehicles with the B4 bogies that could achieve 110mph were actually classified as NEX, and all were originally built with BR1B bogies, limited to 90mph. However, since we do not currently simulate the difference between the 1B (90mph) and Commonwealth (heavier, 100mph) bogies, and especially since I suspect that the 90mph limit was imposed retrospectively rather than existing from the beginning, I have incorporated this change without further refinement for the present, although consideration may need to be given to adding this refinement in the future.

Offline Rollmaterial

  • Devotee
  • *
  • Posts: 621
  • OS: Windows 10
  • Languages: EN, FR, DE, FI, SE
Re: Mark 1 BG has the wrong top speed
« Reply #2 on: January 25, 2021, 02:27:21 PM »
I see the pull request hasn't been merged.

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Administrator
  • *
  • Posts: 20715
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Mark 1 BG has the wrong top speed
« Reply #3 on: January 25, 2021, 03:26:49 PM »
I see the pull request hasn't been merged.

Oops - I forgot to push after merging. Now done.