Simutrans Tools
Know our tools that can help you to create add-ons, install and customize Simutrans.

Cursor in underground mode not working properly

Started by Mariculous, January 17, 2021, 04:46:53 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I have just noticed that on Stephenson-siemens, the cursor does not seem to work in underground mode below a level of -12.
That means, when any tunnels are below that level, those cannot be focused in underground mode, but if the ground above is higher than -12, then the cursor will focus the groound level.
If that level is also below -12, then the cursor won't work at all. It will simply disappear and scrolling won't work as well.
Edit: Also confirmed on a new map. This is general, not stephenson-siemens specific.


I am aware that Standard has issues with extremes of height - can anyone confirm whether this issue can be reproduced in Standard?
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.


I have no idea, but might indeed have been incorporated recently, as that limit was much lower before.


If I remember correctly it is a patch provided by THLeaderH. I think there is a related thread in standard, so please look for it.

These limits can be set in The following are the default values.

# minimum/maximum allowed height level for the map (too high might cause display errors)
# Also those number must no be the same
#world_minimum_height = -12
#world_maximum_height = 32

If implemented correctly, the height limit of 32 has been lifted.

I don't know the rationale for the default setting of -12. But in general I think -12 is deep enough.
Has extended made any changes in the past to lift the underground depth limit? If not, they will get the same changes as the changes in standard.

And it's clear that it's a standard's bug brought about by that patch that you can dig below -12 regardless of the settings and not select tiles less than -12.

The following is a demo image that the symptom can be confirmed even with pak64 with standard.

So, please move this thread to the standard's bug report.


Quote from: Ranran on January 18, 2021, 10:17:40 AMBut in general I think -12 is deep enough.
Have a look at stephenson-siemens. Even sea level is below -12
There also had been a lower limit before, but it was much lower than -12. Not exactly sure about it, but I guess it was somewhere around -22.


I have tried with fresh map with sea level=0. The "classic" underground mode is usable only down to -12. But Using sliced underground mode I was able to go to -25 (and did not try deeper).
I tried also terraforming below sea level, and got quite funny result. "Classic" up/down slope did not let me below sea level, saying that "terraforming in deep water is forbidden". But I was able to get to -3 with "artificial" slopes. Going to -4 hit the underground water.
EDIT: this is not possible in the last nightly. No way to go deeper than -12.

Also this may be related with,

I have modified the wolrd_min|max_height in stephenson-siemens game, and now it works as before. - abel to edit from -30 to +50