The International Simutrans Forum

 

Author Topic: Disable midi option is not saved  (Read 244 times)

0 Members and 1 Guest are viewing this topic.

Offline Ranran

  • Devotee
  • *
  • Posts: 1511
  • Languages: ja
Disable midi option is not saved
« on: May 02, 2021, 02:29:27 PM »
I've always played Simutrans-Extended with disable midi. This option is no longer saved. So I had to check this option every time I launched the game. But on the other hand, the Music volume is remembered correctly, so I found that setting the Music volume to 0 could work around this problem.
The disable midi option is not currently saved (or doesn't load properly) anyway.
« Last Edit: May 26, 2021, 08:17:53 AM by Ranran »

Offline Roboron

  • Devotee
  • *
  • Posts: 284
    • Las Gal├ícticas Aventuras de Komoyo Diga
  • Languages: ES, EN
Re: Disable midi option is not saved
« Reply #1 on: May 10, 2021, 06:06:42 PM »
I declare myself guilty. Here is the fix which should return the previous behaviour https://github.com/jamespetts/simutrans-extended/pull/377

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Administrator
  • *
  • Posts: 20776
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Disable midi option is not saved
« Reply #2 on: May 16, 2021, 11:25:28 AM »
Thank you for this: now incorporated. Apologies for the delay: am currently exceptionally busy in work so do not have time to look into this in any detail.