News:

Simutrans Forum Archive
A complete record of the old Simutrans Forum.

Graphic error at the edges of the world

Started by Yona-TYT, February 21, 2022, 10:54:01 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Yona-TYT


prissi



prissi

Could you upload it? I descrbe how to reproduce it. If you can reproduce, what is you default.svs. simuconf.tab?

Yona-TYT

Quote from: prissi on February 22, 2022, 10:53:18 PM
Could you upload it? I descrbe how to reproduce it. If you can reproduce, what is you default.svs. simuconf.tab?
I'm not at home and I don't know when I'll be back (2 or 3 days).

If the conf are the default.

Andarix

something similar occurs with draw_outside_tile = 0


Yona-TYT

I can say that I played around with the weather settings a bit.

for example: rough terrain to the maximum, lower the water level a little, lower that of the mountains as well.

prissi

Ok, I suspected some simuconf.tab setting. Thanks, I will check this.

Roboron

I can reproduce this loading the save. It looks like that classical bug of windows xp when moving windows around...

prissi



Yona-TYT


Using linux with ferdora and the version compiled from github.

So generate the map:

Yona-TYT

some buildings are also affected by this problem, will it be some error in the dependencies?.

prissi

#13
This building is rather missing the needs_ground=1 setting in the pakset. Please report in the the pak192 thread.

EDIT:
On the drawing error. I could not reproduce it the r10512 nightly, even with draw_outside_tile=0 in windows with GDI or SDL2. Maybe this was a bug related to SDL and certain drivers and the new resizing code which does no longer enforce a width of 16.

Furthermore, all drawing releavant variables for non-netwrok games are in env_t not in settings. So this shoudl haveen with an y savegame.

Yona-TYT

This may have to do with the pakset, as I've tried with pak.nippon and can't replicate the same behavior.