News:

Simutrans Wiki Manual
The official on-line manual for Simutrans. Read and contribute.

Bug Starting A New Game On Steam

Started by Golden Spike, August 12, 2022, 04:05:45 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Golden Spike

Every time I start a new game (new game, not loading a saved game) something happens to the mini-map view and game cursor that doesn't make the game work right. I can save the map from this problem starting situation, exit the game, load the saved game and have the game work fine. It only messes up when starting a new game for the first time. I've included pictures of the issues to help the devs debug. I don't think I can explain this issue well enough to be of any help.

The first pic is the in-game mini-map view. The yellow shape in the window should be square, not polygonal.

The second pic is the game cursor. The orange square highlighted at the bottom of the pic should be directly under the magnifying glass [cursor] highlighted at the top of the pic. The magnifying glass still works, but I have to place the object of my query in the orange square. Weird, right?

The third pic is all that useful coding stuff to help the debug process. I should also mention that I play Simutrans ON STEAM.


Roboron

I can not reproduce. What system are you playing on?

Yona-TYT

In the second image, I've seen that error with the cursor before, but I don't know how to replicate , it seems to happen randomly.

prissi

It could be a problem with the screen size and SDL. What are your screen settings?