The International Simutrans Forum

 

Author Topic: makeobj error with vehicle  (Read 1264 times)

0 Members and 1 Guest are viewing this topic.

Offline z9999

  • Devotees (Inactive)
  • *
  • Posts: 848
makeobj error with vehicle
« on: June 02, 2009, 03:07:41 PM »
Maybe, you changed fixed_maintenance size from 16bit to 32bit, but didn't change node size, did you ?

Quote
Makeobj-Experimental, based on Makeobj version 50 for Simutrans 102.1 Experimental 3.13 and higher
Experimental version by James E. Petts, derived from Makeobj,
 (c) 2002-2006 V. Meyer , Hj. Malthaner and
M. Pristovsek (). This is open source software, released under the Artistic Licence.

writing invidual files to ./
   reading file ./busses.dat
   writing file ./vehicle.Bus2.pak
      packing vehicle.Bus2
ERROR IN CLASS obj_node_t: invalid parameters (offset=48, size=4, obj_size=50)

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18753
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: makeobj error with vehicle
« Reply #1 on: June 02, 2009, 03:59:35 PM »
Oops! Thank you for spotting that. I shall have to fix that for the next version. Thank you again for your error report!

Edit: Actually, I got home to find a message from Bernd Gabrial that he had fixed the problem himself, and forked my Github repository and added the fix there. Thank you very much indeed, Bernd, for saving me time in fixing the problem - I am very grateful! The fixes will be in the next version.
« Last Edit: June 02, 2009, 07:19:36 PM by jamespetts »