The International Simutrans Forum

 

Author Topic: -Bug 4.3]  (Read 1598 times)

0 Members and 1 Guest are viewing this topic.

Offline Cyrus Hall

  • *
  • Posts: 20
-Bug 4.3]
« on: June 21, 2009, 05:12:41 PM »
Ciao all-

Whenever I try and create a convoy, seemingly of any type, and then click "Start," the message "Incorrect Vehicle assembly: cannot be used." is now displayed, and the unit does not start.

Also, removing a vehicle from the depot window (i.e., clicking it such that it is listed in the bottom of the window frame) crashes consistently.

I'm using Pak128.

Cheers,
Pugget

Oops: just realized this could be from the -DSLIST_FREIGHT define.  Let me try without it.

Edit 2: Indeed, this was the problem.  Appears broken with SLIST_FREIGHT currently.  Fixes both bugs to turn it off.
« Last Edit: June 21, 2009, 05:17:01 PM by Pugget »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18753
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: -Bug 4.3]
« Reply #1 on: June 21, 2009, 06:30:57 PM »
Pugget,

thank you very much for the reports. Oddly, though, I can't reproduce this in Windows, even with SLIST_FREIGHT defined. Do I assume correctly that you are using Linux? I am not sure why you are getting this. SLIST_FREIGHT is used to fix another bug, albeit a much more minor, UI-only bug than this.

Offline Cyrus Hall

  • *
  • Posts: 20
Re: -Bug 4.3]
« Reply #2 on: June 21, 2009, 09:05:17 PM »
James-

Correct, it was a 64-bit Linux build.  Haven't had time to do a debug build with SLIST_FREIGHT turned on, but if I do I'll try and post some more details.

Cheers,
Pugget

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18753
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: -Bug 4.3]
« Reply #3 on: June 21, 2009, 09:42:17 PM »
Pugget,

thank you: very kind. 64-bit builds on Linux have had problems for a while... I'd be very grateful for any debug build to give an idea of the problem, though. In the meantime, I have uploaded a slight revision of 4.3 to Github to enable it to compile with GCC (previously, it gave compile errors not present in MSVC++). You could try to see whether that is any better.