News:

Simutrans.com Portal
Our Simutrans site. You can find everything about Simutrans from here.

Problem of displaying trains

Started by 1318, October 18, 2009, 03:55:12 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

1318

Dear all,
I have a problem of displaying trains.
When the trains move towards NW,NE,SE or SW, the carriages look too close to each another.
Has it  been discussed?

1318

DirrrtyDirk

What pakset are you talking about?
  
***** PAK128 Dev Team - semi-retired*****

VS

Hello!

Originally these directions used bad distance and this was later fixed. But some vehicles painted before this change "fixed" this by using longer graphics. Now with correct length the long graphics are stuck into each other. This is "good" from perspective of program and it's the pak (addon?) that has it wrong.

You did not say with what and where this happens, so I assume it's some addon...

My projects... Tools for messing with Simutrans graphics. Graphic archive - templates and some other stuff for painters. Development logs for most recent information on what is going on. And of course pak128!

1318

I'm sorry about forgeting to tell you which pakset I'm using. :-[
I'm using pak 128 with addons.

The problem also happen on the paks without using longer graphics.(Including the original pakset)
The carriages are stuck into each other.
Is this just because of the adjustment?

DirrrtyDirk

Even the "old" graphics are often a little too long for the new mechanism. Graphics that were adjusted to fill the gaps in the old mechanism are now much too long. But correcting this is somewhat painstaking. If you want to see what it looked like earlier, just change (or add) "diagonal_multiplier=1024" in your simutrans/pak128/config/simuconf.tab - you will see that this leads to huge gaps for most vehicles - so the new system is actually to be preferred, even when some graphics would still need a little workover...
  
***** PAK128 Dev Team - semi-retired*****

1318

Quote from: DirrrtyDirk on October 19, 2009, 08:33:11 AM
Even the "old" graphics are often a little too long for the new mechanism. Graphics that were adjusted to fill the gaps in the old mechanism are now much too long. But correcting this is somewhat painstaking. If you want to see what it looked like earlier, just change (or add) "diagonal_multiplier=1024" in your simutrans/pak128/config/simuconf.tab - you will see that this leads to huge gaps for most vehicles - so the new system is actually to be preferred, even when some graphics would still need a little workover...
I have added it in "program settings" and it worked.
Thanks for you help.