The International Simutrans Forum

 

Author Topic: Choice signal doesn't work with "rail close" signal  (Read 2083 times)

0 Members and 1 Guest are viewing this topic.

Offline Amelek

  • *
  • Posts: 70
Choice signal doesn't work with "rail close" signal
« on: February 24, 2010, 07:21:37 PM »
In such situation:



train fails to find route to next platform. It however, do finds route to it's primary platform if it's free. [= Choice signal acts like simple signal]
« Last Edit: February 26, 2010, 03:32:29 PM by IgorTekton »

Offline rsdworker

  • *
  • Posts: 281
Re: Choice signal doesn't work with "rail close" signal
« Reply #1 on: February 24, 2010, 08:45:08 PM »
well the guide should show the layout of signals the choice should be at start of entrance and the end signal should be not in station area - the end signal is primarlly for branching off before station platforms

btw what your version?

Offline Amelek

  • *
  • Posts: 70
Re: Choice signal doesn't work with "rail close" signal
« Reply #2 on: February 24, 2010, 09:03:49 PM »
it's pak64 and latest svn head. This is not end-of-choice sign (which looks different in pak64) but rather one-way-sign (that doesn't behave like signal in terms of blocking). It's clearly problem of sign and not signals at and of platforms because when I remove one-way-sign problem is gone.

It was however used in my game long ago and now it's a bother to fix this :f

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4869
  • Languages: EN, DE, AT
Re: Choice signal doesn't work with "rail close" signal
« Reply #3 on: July 29, 2010, 09:03:36 AM »
works again in rev 3577 (thanks to z9999)