Started by felo, March 10, 2010, 05:48:22 PM
0 Members and 1 Guest are viewing this topic.
Quote from: Memzeron on February 10, 2012, 10:45:40 AMAt the moment my code compiles quicker, that saves each developer some minutes for each full build already.
Quote from: jamespetts on February 10, 2012, 10:53:24 AMOf course, if the Standard developers wanted to translate the code, and be able to use parts from Iron Byte, they could just adopt Hajo's translations
QuoteI shall make patches and wait days for them to be include?
Quote from: whoami on May 30, 2012, 06:01:45 PMThe problem not so much with the code, but with the comments:They are not treated specially yet, but I intend to change this. The current state leads to the ugly effect that single words in German comments are translated (rather than feeding whole paragraphs to some Babelfish successor ). However, I cannot simply omit stuff in comments, because they often refer to identifiers, some even contain commented-out code lines, and they are used by diff. This will not be solvable in an optimal way. (If there are nested /**/ comments, they make handling even more difficult - I would rather remove nesting by separate patches.)
Quote from: sdog on May 30, 2012, 06:17:03 PMYou could add a line below comments where you put the translated and untranslated strings in a fixed format. The comments likely have to be translated by hand and patched by their own. This note will give translators a way to know that variables have changed in the meantime.
Quote"[...] code already using English identifiers that are the same as natural translations of the German ones."I'm afraid, I dont' understand this.
Quote from: prissi on May 30, 2012, 07:06:58 PMAdding a suffix will not change anything but rather cause more confusion. get_way or get_way_en for instance ?!?
Quote from: whoami on May 30, 2012, 06:01:45 PMchecking for any conflicts beforehand, which is possible because the whole relevant code is accessible.
Quote from: jk271 on May 30, 2012, 08:36:22 PMI suggest to translate "spieler_t" to "company_t", not "player_t". I have read here in forum some time ago about intention to enable more players (persons) to control one transport company. Today players can do it too, but they have to share password. Such a translation change would avoid confusion in future: Implementation of unique password for each players would probably need keyword "player" as a class name.
QuoteOh, and the filenames and folder names could be translated automatically, too (of course changing the #include lines).
Quote from: Dwachs on June 05, 2012, 06:41:27 AMMoving & Renaming files is a rather trivial part compared to this.
Quotebetter still if an expert in the code can update them and give them uniformity or a standard format