News:

Beta test the new forum at https://simutrans.forum/

The Forum Rules and Guidelines
Our forum has Rules and Guidelines. Please, be kind and read them ;).

[Bug/fix] Monuments

Started by jamespetts, March 26, 2010, 12:53:32 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

jamespetts

Two of the monuments (the knight and the war memorial) were not showing in the game. I tracked the problem down to the use of the "-" character in the names, which I replaced with the underscore ("_"). Below are the fixed attractions:


Obj=building
name=Knight_Monument
type=mon
intro_year=1700
intro_month=12
build_time=1000
chance=100
passengers=20
dims=1,1,4
needs_ground=1
BackImage[0][0][0][0][0][0]=images/mon/knight-monument.0.0
BackImage[1][0][0][0][0][0]=images/mon/knight-monument.0.3
BackImage[2][0][0][0][0][0]=images/mon/knight-monument.0.2
BackImage[3][0][0][0][0][0]=images/mon/knight-monument.0.1
BackImage[0][0][0][0][0][1]=images/mon/knight-monument.1.0
BackImage[1][0][0][0][0][1]=images/mon/knight-monument.1.3
BackImage[2][0][0][0][0][1]=images/mon/knight-monument.1.2
BackImage[3][0][0][0][0][1]=images/mon/knight-monument.1.1



Obj=building
name=War_Memorial
type=mon
intro_year=1918
intro_month=11
retire_year=1950
retire_month=1
build_time=1000
chance=10
passengers=20
dims=1,1,4
needs_ground=1
BackImage[0][0][0][0][0][0]=images/mon/war-memorial.0.0
BackImage[1][0][0][0][0][0]=images/mon/war-memorial.0.3
BackImage[2][0][0][0][0][0]=images/mon/war-memorial.0.2
BackImage[3][0][0][0][0][0]=images/mon/war-memorial.0.1
BackImage[0][0][0][0][0][1]=images/mon/war-memorial.1.0
BackImage[1][0][0][0][0][1]=images/mon/war-memorial.1.3
BackImage[2][0][0][0][0][1]=images/mon/war-memorial.1.2
BackImage[3][0][0][0][0][1]=images/mon/war-memorial.1.1


The relevant part of en.tab will need to be updated as follows:


Knight_Monument
Monument of a Knight
War_Memorial
War Memorial
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

The Hood

These have always worked for me - what exactly is the problem?  Easy enough to change though.

jamespetts

The monuments simply don't appear in the game when the hyphenated form of the name is used. At least, they don't for me...
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

The Hood

Which game and pak version?  Windows I presume, which makes it hard for me to test.  Would be interesting if anyone else is having similar problems.  I'm most definitely not (1.07 and r3055, and indeed have had these monuments in test games for all the time I can remember...)

jamespetts

Windows indeed, and the latest binary release. I was using -Experimental, but it's hard to see how that would affect this issue.
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.